Bug 1283978 - unable to edit widgets in dashbaord
unable to edit widgets in dashbaord
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Dávid Halász
Taras Lehinevych
dashboard:ui
:
: 1283922 1287767 (view as bug list)
Depends On:
Blocks: 1289334
  Show dependency treegraph
 
Reported: 2015-11-20 07:40 EST by Aziza Karol
Modified: 2016-08-02 21:32 EDT (History)
6 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1289334 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:04:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
snapshot (88.95 KB, image/png)
2015-11-20 07:40 EST, Aziza Karol
no flags Details

  None (edit)
Description Aziza Karol 2015-11-20 07:40:00 EST
Created attachment 1097175 [details]
snapshot

Description of problem:


Version-Release number of selected component (if applicable):
5.5.0.11

How reproducible:
100%

Steps to Reproduce:
1.Navigate to cloud intelligence->reports->dashboards
2.create a dashboard by adding widgets in any group and save
3.try editing the widgets in dashboard

Actual results:
unable to edit widgets in dashboard.no remove option. see attached screenshot

Expected results:
remove option should be available.

Additional info:
Comment 2 Harpreet Kataria 2015-11-24 18:11:59 EST
David,

Can you look into this one, looks like Remove Widget link is in there but no icon is being displayed, maybe patternfly conversion issue.

Let me know if you have questions.

Thanks,
~Harpreet
Comment 3 Harpreet Kataria 2015-11-25 13:15:24 EST
*** Bug 1283922 has been marked as a duplicate of this bug. ***
Comment 4 Harpreet Kataria 2015-12-02 12:53:35 EST
*** Bug 1287767 has been marked as a duplicate of this bug. ***
Comment 5 CFME Bot 2015-12-02 14:45:24 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/bb67757e50344746cc7d2554e490c25eaab28970

commit bb67757e50344746cc7d2554e490c25eaab28970
Author:     Dávid Halász <dhalasz@redhat.com>
AuthorDate: Mon Nov 30 15:29:41 2015 +0100
Commit:     Dávid Halász <dhalasz@redhat.com>
CommitDate: Mon Nov 30 15:31:02 2015 +0100

    Convert .delbox to fontawesome and display it in the widget editor
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1283978

 app/views/report/_db_widget_remove.html.haml | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
Comment 6 CFME Bot 2015-12-07 17:28:51 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=2055264b96b73d6e237dd6d5dcd7878fe1cf221c

commit 2055264b96b73d6e237dd6d5dcd7878fe1cf221c
Merge: fbbaaa5 6c4636d
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Mon Dec 7 17:24:59 2015 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Mon Dec 7 17:24:59 2015 -0500

    Merge branch 'bz-1283978' into '5.5.z'
    
    Convert .delbox to fontawesome and display it in the widget editor
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1283978
    
    5.5 BZ: https://bugzilla.redhat.com/show_bug.cgi?id=1289334
    
    Clean cherry pick from: https://github.com/ManageIQ/manageiq/pull/5642
    (cherry picked from commit bb67757e50344746cc7d2554e490c25eaab28970)
    
    See merge request !572

 app/views/report/_db_widget_remove.html.haml | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
Comment 7 CFME Bot 2015-12-07 17:28:59 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=6c4636d21a3f5d21134a69269397cee0046aed53

commit 6c4636d21a3f5d21134a69269397cee0046aed53
Author:     Dávid Halász <dhalasz@redhat.com>
AuthorDate: Mon Nov 30 15:29:41 2015 +0100
Commit:     Dávid Halász <dhalasz@redhat.com>
CommitDate: Wed Dec 2 16:51:37 2015 +0100

    Convert .delbox to fontawesome and display it in the widget editor
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1283978
    Clean cherry pick from: https://github.com/ManageIQ/manageiq/pull/5642
    (cherry picked from commit bb67757e50344746cc7d2554e490c25eaab28970)

 app/views/report/_db_widget_remove.html.haml | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
Comment 8 Taras Lehinevych 2016-04-19 06:58:42 EDT
Verified in 5.6.0.1-beta2
Comment 10 errata-xmlrpc 2016-06-29 11:04:30 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.