Bug 1284357 - Data Tiering: Change the error message when a detach-tier status is issued on a non-tier volume
Data Tiering: Change the error message when a detach-tier status is issued on...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: hari gowtham
bugs@gluster.org
: ZStream
Depends On: 1236020
Blocks: 1245935 1248337 1260923 1285793
  Show dependency treegraph
 
Reported: 2015-11-23 01:35 EST by hari gowtham
Modified: 2016-06-16 09:46 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1236020
: 1285793 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:46:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-11-23 01:37:28 EST
REVIEW: http://review.gluster.org/12713 (Tiering: change of error message for "v tier <vname>  detach status") posted (#1) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 2 Vijay Bellur 2015-11-24 00:13:41 EST
REVIEW: http://review.gluster.org/12713 (Tiering: change of error message for "v tier <vname>  detach status") posted (#2) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 3 Vijay Bellur 2015-11-24 05:09:49 EST
REVIEW: http://review.gluster.org/12713 (Tiering: change of error message for "v tier <vname>  detach status") posted (#3) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 4 Vijay Bellur 2015-11-25 08:03:39 EST
REVIEW: http://review.gluster.org/12713 (Tiering: change of error message for "v tier <vname>  detach status") posted (#4) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 5 Vijay Bellur 2015-11-26 04:54:48 EST
REVIEW: http://review.gluster.org/12713 (Tiering: change of error message for "v tier <vname>  detach status") posted (#5) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 6 Vijay Bellur 2015-11-26 08:29:50 EST
COMMIT: http://review.gluster.org/12713 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit 7d95955cd2b2b8979e66bcf09e792a34a12bd8a3
Author: hari gowtham <hgowtham@redhat.com>
Date:   Mon Nov 23 11:58:52 2015 +0530

    Tiering: change of error message for "v tier <vname>  detach status"
    
    If the volume was not a tiered volume then empty status was being
    printed instead of an error message.
    
    Change-Id: I13ccb16e1562966976a48d9365ced4c8a124de59
    BUG: 1284357
    Signed-off-by: hari gowtham <hgowtham@redhat.com>
    Reviewed-on: http://review.gluster.org/12713
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
Comment 7 Niels de Vos 2016-06-16 09:46:08 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.