Bug 1285793 - Data Tiering: Change the error message when a detach-tier status is issued on a non-tier volume
Data Tiering: Change the error message when a detach-tier status is issued on...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.6
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: hari gowtham
bugs@gluster.org
: ZStream
Depends On: 1236020 1284357
Blocks: 1245935 1248337 1260923
  Show dependency treegraph
 
Reported: 2015-11-26 08:42 EST by hari gowtham
Modified: 2016-04-19 03:49 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1284357
Environment:
Last Closed: 2016-04-19 03:49:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-11-26 08:43:23 EST
REVIEW: http://review.gluster.org/12766 (Tiering: change of error message for "v tier <vname>  detach status") posted (#1) for review on release-3.7 by hari gowtham (hari.gowtham005@gmail.com)
Comment 2 Vijay Bellur 2015-11-30 05:30:05 EST
REVIEW: http://review.gluster.org/12766 (Tiering: change of error message for "v tier <vname>  detach status") posted (#2) for review on release-3.7 by hari gowtham (hari.gowtham005@gmail.com)
Comment 3 Vijay Bellur 2015-11-30 11:20:08 EST
COMMIT: http://review.gluster.org/12766 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit d421c123952ed2059f816e92e57f5e07968cc778
Author: hari gowtham <hgowtham@redhat.com>
Date:   Mon Nov 23 11:58:52 2015 +0530

    Tiering: change of error message for "v tier <vname>  detach status"
    
            back port of : http://review.gluster.org/12713
    
    If the volume was not a tiered volume then empty status was being
    printed instead of an error message.
    
    >Change-Id: I13ccb16e1562966976a48d9365ced4c8a124de59
    >BUG: 1284357
    >Signed-off-by: hari gowtham <hgowtham@redhat.com>
    >Reviewed-on: http://review.gluster.org/12713
    >Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    >Tested-by: Gluster Build System <jenkins@build.gluster.com>
    >Tested-by: Dan Lambright <dlambrig@redhat.com>
    >Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    
    Change-Id: Ica4ed95844eab9a632eea8c35b686a4c1d73f78d
    BUG: 1285793
    Signed-off-by: Hari Gowtham <hgowtham@redhat.com>
    Reviewed-on: http://review.gluster.org/12766
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 4 Kaushal 2016-04-19 03:49:12 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.