Bug 128494 - httpasswd gives error: could not determine temp dir
httpasswd gives error: could not determine temp dir
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: httpd (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
:
: 130405 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-23 12:35 EDT by Troy Davis
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-23 16:47:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Troy Davis 2004-07-23 12:35:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/125.2 (KHTML, like Gecko) Safari/125.8

Description of problem:
I currently have Apache configured to work with Tomcat. When I try to create a new htpasswd file or add users to an existing file, I get this:

# htpasswd -c test testuser
New password: 
Re-type new password: 
htpasswd: could not determine temp dir



Version-Release number of selected component (if applicable):
httpd-2.0.50-2.1

How reproducible:
Always

Steps to Reproduce:
1. Enter "htpasswd -c test testuser" at the command line
2. Enter password
3. Re-type password
    

Actual Results:  The file is created, but no entry is made. The error message given is "htpasswd: could not determine temp dir".

Expected Results:  Valid htpasswd user entry.

Additional info:
Comment 1 Joe Orton 2004-07-23 12:38:24 EDT
If you're really on Fedora Core 2, you need to upgrade to the FC2 apr
package, which doesn't have this bug.  This is a bug in the FC1 apr
package.
Comment 2 Joe Orton 2004-07-23 16:47:27 EDT
Run "up2date apr" to make sure you have the latest apr package for
Fedora Core 2.  If you're really on FC1, this is a dupe of bug 128144.
Comment 3 Andrew Cherry 2004-08-19 21:06:33 EDT
I'm having same issue while using the following packages:

apr-devel-0.9.5-0.3
apr-util-debuginfo-0.9.5-0.4
apr-debuginfo-0.9.5-0.3
apr-util-devel-0.9.5-0.4
apr-util-0.9.5-0.4
apr-0.9.5-0.3

httpd-2.0.50-2.1
httpd-manual-2.0.50-2.1
httpd-devel-2.0.50-2.1

It was working yesterday before I upgraded the httpd packages
Not sure if I need to downgrade the apr packages?
Comment 4 Joe Orton 2004-08-20 02:00:45 EDT
If you have any package version "0.9.5" of apr or apr-util package,
you have third party packages installed (e.g. David Summer's
Subversion package set).  You need to remove these and install Fedora
versions, e.g

service httpd stop
rpm --erase --nodeps apr apr-devel apr-util apr-util-devel
up2date apr apr-util apr-devel apr-util-devel 

Comment 5 Joe Orton 2004-08-20 02:04:01 EDT
*** Bug 130405 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.