Bug 1285296 - update-desktop-database reports error about kgpg desktop file
update-desktop-database reports error about kgpg desktop file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kgpg (Show other bugs)
23
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
: 1295070 1299887 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-25 06:25 EST by David Jansen
Modified: 2016-02-01 01:28 EST (History)
6 users (show)

See Also:
Fixed In Version: kgpg-15.12.1-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-30 13:20:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Jansen 2015-11-25 06:25:41 EST
Description of problem:

The .desktop file of kgpg seems to contain an error. When the package is present on the system, each subsequent run of /usr/bin/update/desktop-database (eg from scripts in other rpms being installed) causes an error message.

Version-Release number of selected component (if applicable):
kgpg-15.08.3-2.fc23.x86_64
desktop-file-utils-0.22-5.fc23.x86_64

How reproducible:


Steps to Reproduce:
1. install kgpg (note, this doesn't give the error, the post scriptlet in the kgpg package redirects output and error to /dev/null)
2. install some other packages, or run /usr/bin/update/desktop-database as root

Actual results:

# update-desktop-database 
Could not parse file "/usr/share/applications/kde4/kgpg.desktop": Invalid key name: X-KDE-autostart-condition[$e]

Expected results:
no output.

Additional info:

Previous versions of kgpg (eg in Fedora 21) had this key without the [$e] and then there is no error.
Comment 1 Rex Dieter 2016-01-21 12:02:33 EST
*** Bug 1295070 has been marked as a duplicate of this bug. ***
Comment 2 Rex Dieter 2016-01-21 12:50:31 EST
*** Bug 1299887 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2016-01-21 12:51:44 EST
kgpg-15.12.1-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-5716086d21
Comment 4 Fedora Update System 2016-01-21 12:52:40 EST
kgpg-15.12.1-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-0140c00e39
Comment 5 Fedora Update System 2016-01-21 23:54:29 EST
kgpg-15.12.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-5716086d21
Comment 6 Fedora Update System 2016-01-23 16:28:16 EST
kgpg-15.12.1-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-0140c00e39
Comment 7 David Jansen 2016-01-25 04:11:45 EST
Thanks, this fixes the issue for me
Comment 8 Fedora Update System 2016-01-30 13:20:53 EST
kgpg-15.12.1-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2016-02-01 01:28:34 EST
kgpg-15.12.1-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.