Bug 12856 - bad arg -A to depmod
bad arg -A to depmod
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
:
: 12972 (view as bug list)
Depends On: 12238
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-23 10:56 EDT by Frank Sweetser
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-07 07:48:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Frank Sweetser 2000-06-23 10:56:37 EDT
rc.sysinit calls depmod with -A instead of -a. -A is invalid, so it fails
out, thereby leaving modules unusable.
Comment 1 Bill Nottingham 2000-06-23 11:00:54 EDT
That's not an invalid flag with the modutils that shipped with beta2 ;
what version do you have installed?
Comment 2 Bill Pemberton 2000-06-23 14:55:13 EDT
I get the same errors too (after a text based upgrade from RH6.2 to beta2).  

From /var/log/messages after the boot:

Jun 23 14:31:07 wfp5ptest12 depmod: depmod: invalid option -- A 
Jun 23 14:31:07 wfp5ptest12 depmod: depmod 2.3.10-pre1 
Jun 23 14:31:07 wfp5ptest12 depmod: depmod -a [-n -e -v -q -V] 

[and so on]

rpm -qf /sbin/depmod says "modutils-2.3.9-6".  I see the CD has 
modutils-2.3.11-6, so it looks like the update didn't update modutils.

Installing modutils-2.3.11-6 by hand fixes the error.
Comment 3 Bill Nottingham 2000-06-23 15:21:53 EDT
Hm, OK, looks like an installer problem in that it didn't install the
new modutils. Reassigned to the installer.
Comment 4 Bill Nottingham 2000-07-06 17:03:57 EDT
This should be fixed in beta3.
Comment 5 Bill Nottingham 2000-07-06 17:04:16 EDT
*** Bug 12972 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.