Bug 12972 - depmod invalid option -- A
depmod invalid option -- A
Status: CLOSED DUPLICATE of bug 12856
Product: Red Hat Linux
Classification: Retired
Component: modutils (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On: 12238
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-23 21:01 EDT by Chris Runge
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-06 16:55:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Runge 2000-06-23 21:01:01 EDT
after upgrading from 6.2, the initial boot says the following:

Finding module dependencies depmod: invalid option -- A
depmod 2.3.10-pre1
depmod -a [-n -e -v -q -V]
       [-C configfile] [-F kernelsyms] [-b basedirectory] [forced_version]
depmod [-n -e -v -q] [-f kernelsysms] module1.o module2.o ...
If no arguments (expect options) are given, "depmod -a" is assumed

depmod will output a dependency list suitable for the modprobe utility.
depmod -a will find the list of moduules to probe from the file
/etc/modules.conf. It will output the result into the depfile specified
in this configuration file

Normally depmod operates silently, reporting only the list of modules that
won't load properly (missing symbols).
Option -q will make depmod keep quiet about missing symbols
Option -e output all the unresolved symbol for a given module
Comment 1 Pekka Savola 2000-06-26 10:39:30 EDT
This almost certainly happens because you had mkbootdisk installed before, and
modutils didn't get updated because of conflicts!

Comment 2 Bill Nottingham 2000-07-06 17:04:17 EDT

*** This bug has been marked as a duplicate of 12856 ***

Note You need to log in before you can comment on or make changes to this bug.