Bug 1285755 - Service reconfigure screens fails to show the values set for static dropdown and radio button during service provsioning
Service reconfigure screens fails to show the values set for static dropdown ...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Harpreet Kataria
Aziza Karol
service:reconfigure
: ZStream
Depends On:
Blocks: 1286843 1289282 1293711
  Show dependency treegraph
 
Reported: 2015-11-26 06:52 EST by Aziza Karol
Modified: 2016-06-29 11:12 EDT (History)
7 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1289282 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:12:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2115141 None None None 2016-01-08 01:46 EST

  None (edit)
Description Aziza Karol 2015-11-26 06:52:30 EST
Created attachment 1099258 [details]
dialog

Description of problem:
During a service reconfiguration, values of dropdown field and radio buttons are
resetted to default values and not the one which were set during service provisioning

Version-Release number of selected component (if applicable):
5.5.0.12-rc2.20151124135609_653c0d4 

How reproducible:
100%

Steps to Reproduce:
1.create a service dialog having elements  static texbox,static dropdown,static check box and static radio by setting it to default values.refer dialog screenshot.
2.provision an orchestration service using this dialog and while provisioning set the values to new values and submit the request. refer provision screenshot
3.After provision is successful,navigate to service->my services and reconfigure the service.
In the reconfigure service page,the static checkbox and textbox shows the new value but static dropdown and radio button value is resetted to default value.
This two elements should also show new value which was assigned while provisioning.refer reconfigure screenshot

Actual results:
During a service reconfiguration, values of dropdown field and radio buttons are
resetted to default values and not the one which were set during service provision.

Expected results:
Should show updated values in reconfigure screen.

Additional info:
Comment 4 Harpreet Kataria 2015-12-01 11:29:53 EST
https://github.com/ManageIQ/manageiq/pull/5651
Comment 5 CFME Bot 2015-12-03 15:51:12 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/287b0c4633c4da5acd6b98aa4ea55aa853fb85f9

commit 287b0c4633c4da5acd6b98aa4ea55aa853fb85f9
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Thu Dec 3 13:58:34 2015 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Thu Dec 3 14:03:35 2015 -0500

    Changed code to not store params[:typ] in @edit to fix brakeman error
    
    Changed checks for @edit[:stamp_typ] value appropriately.
    Fixed merge conflicts on the spec test
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1285755

 app/controllers/miq_request_controller.rb       |  7 ++++---
 app/views/miq_request/_request.html.haml        |  2 +-
 spec/helpers/application_helper/dialogs_spec.rb | 15 ++++++++-------
 3 files changed, 13 insertions(+), 11 deletions(-)
Comment 6 CFME Bot 2015-12-03 15:51:17 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/1fadf8c07c159780f0844dc86c0c4c6e55538853

commit 1fadf8c07c159780f0844dc86c0c4c6e55538853
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Mon Nov 30 14:04:07 2015 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Thu Dec 3 14:01:37 2015 -0500

    Fixed static drop down & radio button to show selected values correctly.
    
    Changed radio_options helper method to pass in selected value of radio button field that was saved when service was ordered so it can be displayed correctly on reconfigure service screen.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1285755

 app/helpers/application_helper/dialogs.rb                       | 4 ++--
 app/views/shared/dialogs/_dialog_field_drop_down_list.html.haml | 2 +-
 app/views/shared/dialogs/_dialog_field_radio_button.html.haml   | 2 +-
 3 files changed, 4 insertions(+), 4 deletions(-)
Comment 8 CFME Bot 2015-12-08 16:14:53 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=9ab2a50fac0e16b82b5cdd2f43c7c7b016de06ae

commit 9ab2a50fac0e16b82b5cdd2f43c7c7b016de06ae
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Mon Nov 30 14:04:07 2015 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Mon Dec 7 13:36:26 2015 -0500

    Fixed static drop down & radio button to show selected values correctly.
    
    Changed radio_options helper method to pass in selected value of radio button field that was saved when service was ordered so it can be displayed correctly on reconfigure service screen.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1285755
    (cherry picked from commit 1fadf8c)

 app/helpers/application_helper/dialogs.rb                      |  4 ++--
 .../shared/dialogs/_dialog_field_drop_down_list.html.haml      | 10 +++++-----
 app/views/shared/dialogs/_dialog_field_radio_button.html.haml  |  2 +-
 3 files changed, 8 insertions(+), 8 deletions(-)
Comment 9 CFME Bot 2015-12-08 16:14:57 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=8956610a8dc53c3276485d1a5f654ceb7b600c5f

commit 8956610a8dc53c3276485d1a5f654ceb7b600c5f
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Thu Dec 3 13:58:34 2015 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Tue Dec 8 09:10:13 2015 -0500

    Changed code to not store params[:typ] in @edit to fix brakeman error
    
    Changed checks for @edit[:stamp_typ] value appropriately.
    Fixed merge conflicts on the spec test
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1285755
    (cherry picked from commit 287b0c4)

 app/controllers/miq_request_controller.rb       |   7 +-
 app/views/miq_request/_request.html.haml        |   2 +-
 spec/helpers/application_helper/dialogs_spec.rb | 161 ++++++++++++------------
 3 files changed, 86 insertions(+), 84 deletions(-)
Comment 10 Aziza Karol 2016-05-06 06:50:21 EDT
During a service reconfiguration, values of dropdown field and radio buttons shows
updated values which were set during service provision.


Verified:5.6.0.5-beta2.4.20160503153816_1fb554f
Comment 12 errata-xmlrpc 2016-06-29 11:12:03 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.