Bug 128588 - user account creation has incorrect keyboard layout
Summary: user account creation has incorrect keyboard layout
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: firstboot   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
: 129556 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-26 20:12 UTC by Laurent Coudeur
Modified: 2007-11-30 22:10 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-06 15:58:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Laurent Coudeur 2004-07-26 20:12:57 UTC
Description of problem:
after installing Fedora Core version 2.90 Test 1 The user account
creation used US / English keyboard layout instead of French

Version-Release number of selected component (if applicable):
Fedora Core 2.90 Test 1

How reproducible:
Install Fedora using English Language (default) and French keyboard

Steps to Reproduce:
1.on first reboot create a user account such as "laurent"
2.
3.
  
Actual results:
you will get account name lqurent
the root password and user password used correct mapping
Expected results:


Additional info:

Comment 1 Laurent Coudeur 2004-07-26 20:16:15 UTC
I looked for this in your bugzilla database and could not find this I
hope this is an anaconda issue as this was during setup.
I forgot to mention I did standard installation apart from my keyboard
layout and Dublin Location

Comment 2 Bill Nottingham 2004-08-10 21:14:42 UTC
*** Bug 129556 has been marked as a duplicate of this bug. ***

Comment 3 Carl-Johan Kjellander 2004-09-07 22:57:51 UTC
I can confirm that firstboot doesn't use the keyboard layout
you've selected. We've installed 9 computers with FC2 and selected
'sv-latin1' as our keyboard layout, but still, firstboot uses
the US keyboard.

The layout works fine as soon as GDM starts.

Comment 4 Fred New 2004-10-13 10:36:42 UTC
This problem is still happening with FC3T3. The password created
during firstboot has to be corrected once the new system is available.
(I am using an Estonian keyboard.)

Comment 5 Pierre-Yves Berger 2004-10-16 10:05:32 UTC
It seems that firstboot uses the default keyboard layout proposed in anaconda for the 
language used for the installation. 
I tried French as installation language and I ended up with a french keyboard layout 
(AZERTY) instead of the swiss french (QWERTZU) I selected during anaconda setup.

The problem occurs during the whole initial setup but neither in anaconda nor in gdm.

Comment 6 David Balažic 2004-11-15 13:11:42 UTC
This looks like a duplicate of bug 100686, which also has more info
and even patches. It also claims FIXED/RAWHIDE.

Comment 7 Chris Lumens 2005-09-23 17:52:11 UTC
Please try upgrading to the latest release and seeing if you still experience
problems.


Note You need to log in before you can comment on or make changes to this bug.