Bug 1286687 - VMs are loosing their nics upon previewing a live snapshot
VMs are loosing their nics upon previewing a live snapshot
Status: CLOSED DUPLICATE of bug 1270583
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt (Show other bugs)
3.6.0.2
Unspecified Unspecified
urgent Severity urgent (vote)
: ---
: ---
Assigned To: Alona Kaplan
Ilanit Stein
network
: Regression
: 1286685 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-30 08:54 EST by Ori Gofen
Modified: 2016-05-25 21:50 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-02 03:50:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ogofen: planning_ack?
ogofen: devel_ack?
ogofen: testing_ack?


Attachments (Terms of Use)
logs (3.87 MB, application/x-gzip)
2015-11-30 09:16 EST, Ori Gofen
no flags Details
vdsm.log (1.82 MB, text/plain)
2015-11-30 09:22 EST, Ori Gofen
no flags Details

  None (edit)
Description Ori Gofen 2015-11-30 08:54:39 EST
Description of problem:
Vms are loosing their network interfaces when they are restarted at preview mode.
In case of previewing a VM with cinder as a storage provider, the VM starts booting 'normally', without loading the ram image, also the VM has no network interfaces, decided not to open a separate bug for cinder as it is seem to be same issue.

This behavior is not reproducible on RHEVM 3.5

Version-Release number of selected component (if applicable):
rhevm-3.6.1-0.2.el6.noarch

How reproducible:
100%

Steps to Reproduce: 

[Cinder Storage]
1.preview a VM with ram snapshot enabled(restored)

[other storage]
1.preview a VM with ram snapshot enabled(restored)
2.start the VM, power off the VM
3.start the VM

Actual results:
VMs are loosing connectivity and in case of cinder as backend ram is not restored.

Expected results:
VM shouldn't loose it's connectivity, live snapshots should be previewed

Additional info:
Comment 1 Daniel Erez 2015-11-30 09:14:00 EST
Looking at the affected environment, seems that the nic of the VM is unplugged on previewing. @Alona - any recent issue regarding restoring nic status when previewing a snapshot?
Comment 2 Ori Gofen 2015-11-30 09:16 EST
Created attachment 1100511 [details]
logs
Comment 3 Ori Gofen 2015-11-30 09:22 EST
Created attachment 1100512 [details]
vdsm.log
Comment 4 Ori Gofen 2015-11-30 09:25:16 EST
This will probably be two separate bugs, one on the disconnected nic while previewing a snapshot, and one on cinder->ram issue.
Comment 5 Tal Nisan 2015-11-30 10:17:53 EST
I really don't get how are the two issues connected, please open a bug separate bug for each of the two issues
Comment 6 Ori Gofen 2015-11-30 11:11:27 EST
*** Bug 1286685 has been marked as a duplicate of this bug. ***
Comment 7 Alona Kaplan 2015-12-01 04:32:00 EST
As far as I know, the plugged/unplugged state of the nic is not preserved when creating a snapshot.(In reply to Daniel Erez from comment #1)
> Looking at the affected environment, seems that the nic of the VM is
> unplugged on previewing. @Alona - any recent issue regarding restoring nic
> status when previewing a snapshot?

There is a bug regarding it -https://bugzilla.redhat.com/1270583
The fix should be part of 3.6.1.
Comment 8 Ori Gofen 2015-12-01 04:56:25 EST
This bug will handle the interface disconnection issue:

Actual results:
VMs are loosing connectivity during snapshot preview

Expected results:
VMs shouldn't loose their connectivity.
Comment 9 Allon Mureinik 2015-12-01 11:04:53 EST
(In reply to Ori Gofen from comment #8)
> This bug will handle the interface disconnection issue:
> 
> Actual results:
> VMs are loosing connectivity during snapshot preview
> 
> Expected results:
> VMs shouldn't loose their connectivity.
Based on this, this BZ is unrelated to storage - it lays somewhere between the virt and network areas.


(In reply to Alona Kaplan from comment #7)
> As far as I know, the plugged/unplugged state of the nic is not preserved
> when creating a snapshot.(In reply to Daniel Erez from comment #1)
> > Looking at the affected environment, seems that the nic of the VM is
> > unplugged on previewing. @Alona - any recent issue regarding restoring nic
> > status when previewing a snapshot?
> 
> There is a bug regarding it -https://bugzilla.redhat.com/1270583
> The fix should be part of 3.6.1.
Moving to network based on this statement.
Alona - up to you if you just want to close this as a duplicate or do anything else there.
Comment 10 Alona Kaplan 2015-12-02 03:50:22 EST

*** This bug has been marked as a duplicate of bug 1270583 ***

Note You need to log in before you can comment on or make changes to this bug.