Bug 128709 - Syntax in ooo-1.2 setup script
Syntax in ooo-1.2 setup script
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
: 128750 128757 (view as bug list)
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-07-28 10:27 EDT by Sammy
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-25 15:37:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sammy 2004-07-28 10:27:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux; X11; en_US, en_US.UTF-8, en) (KHTML, like Gecko)

Description of problem:
There seems to be a syntax error (line 155) in the /usr/lib/ooo-1.1/program/setup
file that prevents any program from starting.

Version-Release number of selected component (if applicable):
openoffice.org-1.1.2-1

How reproducible:
Always

Steps to Reproduce:
1.install openoffice.org-1.1.2-1
2.start something manually
3.
    

Additional info:
Comment 1 Dan Williams 2004-07-28 11:32:06 EDT
It starts just fine for me...  Is there some reason your Perl is
erroring out instead of just spitting out a warning?

(in any case, this should be fixed but it should not be stopping a launch)
Comment 2 Sammy 2004-07-28 12:07:22 EDT
Well, I am using the new perl-5.8.5-2 from rawhide. It sais the "else" is 
a syntax error and it exits: Here is the error: 
 
# ./setup 
./setup: line 159: syntax error near unexpected token `else' 
./setup: line 159: `   else' 
 
Also, if you have this and try to start oowriter you get: 
 
# oowriter 
Installation of OpenOffice.org 1.1.2 failed: 
 'LD_LIBRARY_PATH=/usr/lib/ooo-1.1:/usr/lib/ooo-1.1/program /usr/lib/ooo-1.1/program/setup 
-R:/etc/openoffice/autoresponse.conf -v -nogui > ~/.openoffice-install-log 2>&1' 
 
Comment 3 Dan Williams 2004-07-28 13:08:27 EDT
Aha, correct you are.
Comment 4 Dan Williams 2004-07-29 09:12:51 EDT
*** Bug 128750 has been marked as a duplicate of this bug. ***
Comment 5 Dan Williams 2004-07-29 09:13:16 EDT
*** Bug 128757 has been marked as a duplicate of this bug. ***
Comment 6 Dan Williams 2004-09-25 15:37:59 EDT
Please test with the openoffice.org-1.1.2-5 RPMs in Rawhide, it should
be fixed in that version.  If the problem persists with that version,
please reopen this bug.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.