Bug 1287204 - Entry Point (NS/Cls/Inst) browser for service dialog elements fails to display available Instances
Entry Point (NS/Cls/Inst) browser for service dialog elements fails to displa...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Robin Knaur
Kyrylo Zvyagintsev
:
Depends On:
Blocks: 1289693
  Show dependency treegraph
 
Reported: 2015-12-01 13:31 EST by Peter McGowan
Modified: 2016-06-29 11:14 EDT (History)
7 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1289693 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:14:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
datastore export (590.17 KB, application/zip)
2015-12-01 13:31 EST, Peter McGowan
no flags Details
dialog export (30.56 KB, text/x-vhdl)
2015-12-01 13:31 EST, Peter McGowan
no flags Details
instances under method (99.26 KB, image/png)
2015-12-09 07:46 EST, Robin Knaur
no flags Details
Correct display of Instances in the datastore explorer (70.71 KB, image/png)
2015-12-09 08:23 EST, Peter McGowan
no flags Details
Instances missing when using the Entry Point (NS/Cls/Inst) browser (40.17 KB, image/png)
2015-12-09 08:24 EST, Peter McGowan
no flags Details

  None (edit)
Description Peter McGowan 2015-12-01 13:31:21 EST
Created attachment 1100983 [details]
datastore export

Description of problem:
The Dynamic Service Dialog Element Entry Point (NS/Cls/Inst) browser fails to display available Instances

Version-Release number of selected component (if applicable):
CFME 5.5.0.12-rc2.20151124135609_653c0d4

How reproducible:
Every time

Steps to Reproduce:
1) Import the attached domain and service dialog exports.

2) Edit the dialog 'Generic Server Managed by Satellite 6'

3) Edit the Host Group element, and browse to ACME/Integration/Satellite/DynamicDialogs/Methods/ListHostGroups.
Click Apply

4) Edit the Activation Key element and attempt browse to ACME/Integration/Satellite/DynamicDialogs/Methods/ListActivationKeys. 

Actual results:
I see no instances under Methods.

Expected results:
I should be able to browse the instances under the class

Additional info:
Comment 2 Peter McGowan 2015-12-01 13:31 EST
Created attachment 1100984 [details]
dialog export
Comment 4 Peter McGowan 2015-12-08 13:28:41 EST
This is a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1289693 (not https://bugzilla.redhat.com/show_bug.cgi?id=1286505)

This BZ refers to the entry point browser for Dynamic Service Dialog Elements. 1286505 refers to the entry point browser when creating Service Catalog Items.

The two may be caused by the same underlying piece of code / bug, but IMO should still be kept as separate BZs to validate the fix in both.

Note that this BZ describes a separate issue to the scrolling problem (BZ1283603
 I think) that has now been fixed
Comment 5 Robin Knaur 2015-12-09 07:46 EST
Created attachment 1103872 [details]
instances under method
Comment 6 Robin Knaur 2015-12-09 07:50:29 EST
I think that is already fixed, because i see instances under method.
Comment 8 Peter McGowan 2015-12-09 08:23 EST
Created attachment 1103896 [details]
Correct display of Instances in the datastore explorer
Comment 9 Peter McGowan 2015-12-09 08:24 EST
Created attachment 1103897 [details]
Instances missing when using the Entry Point (NS/Cls/Inst) browser
Comment 10 Robin Knaur 2015-12-09 09:11:59 EST
I still think that behavior in my screenshot is correct. Could you try it in upstream? Or give me some more detailed explanation what is wrong there?

Thanks
Comment 12 CFME Bot 2015-12-21 10:40:58 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/15045b427a4644ba4ad8ac200db1f1841634ddf0

commit 15045b427a4644ba4ad8ac200db1f1841634ddf0
Author:     Robin Knaur <rknaur@redhat.com>
AuthorDate: Mon Dec 14 16:18:25 2015 +0100
Commit:     Robin Knaur <rknaur@redhat.com>
CommitDate: Mon Dec 14 16:20:31 2015 +0100

    Entry point service dialog fix
    https://bugzilla.redhat.com/show_bug.cgi?id=1287204

 app/assets/javascripts/miq_dynatree.js      | 4 ++--
 app/views/layouts/_ae_tree_select.html.haml | 3 ++-
 2 files changed, 4 insertions(+), 3 deletions(-)
Comment 14 CFME Bot 2015-12-21 12:44:18 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=ee8f158a9c2888f8efb8ef0e5c723fe8d892234c

commit ee8f158a9c2888f8efb8ef0e5c723fe8d892234c
Author:     Robin Knaur <rknaur@redhat.com>
AuthorDate: Mon Dec 14 10:18:25 2015 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Mon Dec 21 10:33:36 2015 -0500

    Entry point service dialog fix
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1287204
    (cherry picked from commit 15045b4)
    https://bugzilla.redhat.com/show_bug.cgi?id=1289693

 app/assets/javascripts/miq_dynatree.js      | 4 ++--
 app/views/layouts/_ae_tree_select.html.haml | 3 ++-
 2 files changed, 4 insertions(+), 3 deletions(-)
Comment 15 CFME Bot 2015-12-21 12:44:28 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=b63f1410f8c8191cbbb9ba66bd9cbe4f70f790d4

commit b63f1410f8c8191cbbb9ba66bd9cbe4f70f790d4
Merge: 5c0b577 ee8f158
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Mon Dec 21 12:14:34 2015 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Mon Dec 21 12:14:34 2015 -0500

    Merge branch '55z_pr_5832' into '5.5.z'
    
    Entry point service dialog fix
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1287204
    (cherry picked from commit 15045b4)
    https://bugzilla.redhat.com/show_bug.cgi?id=1289693
    
    @dclarizi please review, this is a clean cherry-pick for https://github.com/ManageIQ/manageiq/pull/5832
    
    See merge request !650

 app/assets/javascripts/miq_dynatree.js      | 4 ++--
 app/views/layouts/_ae_tree_select.html.haml | 3 ++-
 2 files changed, 4 insertions(+), 3 deletions(-)
Comment 18 errata-xmlrpc 2016-06-29 11:14:39 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.