Bug 1287221 - dnf stutters when writing in /var/log/dnf.rpm.log
Summary: dnf stutters when writing in /var/log/dnf.rpm.log
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf   
(Show other bugs)
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
: 1288714 1298020 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-12-01 19:37 UTC by Michal Jaegermann
Modified: 2016-02-17 04:23 UTC (History)
7 users (show)

Fixed In Version: dnf-1.1.6-1.fc23 dnf-1.1.6-2.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-17 04:23:28 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2015-12-01 19:37:00 UTC
Description of problem:

dnf fills up /var/log/dnf.rpm.log in such manner

....
Dec 01 11:44:40 INFO Upgraded: kernel-tools-4.2.6-201.fc22.x86_64
Dec 01 11:44:40 INFO Upgraded: kernel-tools-4.2.6-201.fc22.x86_64
....
Dec 01 11:44:44 INFO Cleanup: kernel-tools-4.2.6-200.fc22.x86_64
Dec 01 11:44:44 INFO Cleanup: kernel-tools-4.2.6-200.fc22.x86_64
....

Why and what for?  Not only this makes these logs harder to read and search but also filtering by 'uniq' immediately drops their sizes by half.

Expected results:
dnf not "seeing double".

Comment 1 Michal Luscon 2015-12-08 14:31:18 UTC
*** Bug 1288714 has been marked as a duplicate of this bug. ***

Comment 2 Jaroslav Mracek 2016-01-19 14:13:35 UTC
*** Bug 1298020 has been marked as a duplicate of this bug. ***

Comment 3 Fedora Update System 2016-01-26 10:35:04 UTC
dnf-plugins-core-0.1.16-1.fc23 dnf-1.1.6-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-80cbf309b4

Comment 4 Fedora Update System 2016-01-26 10:36:06 UTC
dnf-plugins-core-0.1.16-1.fc22 dnf-1.1.6-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-573eba7b37

Comment 5 Fedora Update System 2016-01-26 19:53:02 UTC
dnf-1.1.6-1.fc23, dnf-plugins-core-0.1.16-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-80cbf309b4

Comment 6 Fedora Update System 2016-01-28 18:20:25 UTC
dnf-1.1.6-1.fc23, dnf-plugins-core-0.1.16-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2016-01-28 23:19:41 UTC
dnf-1.1.6-1.fc22, dnf-plugins-core-0.1.16-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-573eba7b37

Comment 8 Fedora Update System 2016-02-03 13:07:22 UTC
dnf-1.1.6-2.fc22 dnf-plugins-core-0.1.16-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-573eba7b37

Comment 9 Fedora Update System 2016-02-03 23:27:12 UTC
dnf-1.1.6-2.fc22, dnf-plugins-core-0.1.16-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-573eba7b37

Comment 10 Fedora Update System 2016-02-17 04:22:32 UTC
dnf-1.1.6-2.fc22, dnf-plugins-core-0.1.16-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.