Bug 1287310 - UI: Error while navigating to Container Pod Services Page
Summary: UI: Error while navigating to Container Pod Services Page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.5.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.6.0
Assignee: Daniel Korn
QA Contact: Tony
URL:
Whiteboard: container
: 1289429 (view as bug list)
Depends On:
Blocks: 1288548
TreeView+ depends on / blocked
 
Reported: 2015-12-01 23:06 UTC by Nandini Chandra
Modified: 2016-06-29 15:14 UTC (History)
10 users (show)

Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1288548 (view as bug list)
Environment:
Last Closed: 2016-06-29 15:14:59 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:
ashlifst: automate_bug+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1348 normal SHIPPED_LIVE CFME 5.6.0 bug fixes and enhancement update 2016-06-29 18:50:04 UTC

Description Nandini Chandra 2015-12-01 23:06:47 UTC
Description of problem:
----------------------
The UI blows up with this error while navigating to Container Pod Services Page.

Missing partial container_group/_container_services, application/_container_services with {:locale=>[:en], :formats=>[:html], :variants=>[], :handlers=>[:erb, :builder, :raw, :ruby, :haml, :jbuilder, :rjs]}. Searched in: * "/var/www/miq/vmdb/app/views" * "/opt/rh/rh-ruby22/root/usr/share/gems/gems/redhat_access_cfme-0.0.6/app/views" [container_group/show] 

Snippet from production.log:
[----] F, [2015-12-01T17:56:54.003916 #32416:1257988] FATAL -- : Error caught: [ActionView::MissingTemplate] Missing partial container_group/_container_services, application/_container_services with {:locale=>[:en], :formats=>[:html], :variants=>[], :handlers=>[:erb, :builder, :raw, :ruby, :haml, :jbuilder, :rjs]}. Searched in:
  * "/var/www/miq/vmdb/app/views"
  * "/opt/rh/rh-ruby22/root/usr/share/gems/gems/redhat_access_cfme-0.0.6/app/views"

/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/path_set.rb:46:in `find'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/lookup_context.rb:121:in `find'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/renderer/partial_renderer.rb:418:in `find_template'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/renderer/partial_renderer.rb:413:in `find_partial'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/renderer/partial_renderer.rb:294:in `render'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/renderer/renderer.rb:47:in `render_partial'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/renderer/renderer.rb:21:in `render'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/helpers/rendering_helper.rb:32:in `render'
/opt/rh/cfme-gemset/bundler/gems/jquery-rjs-33e0fc1c0b25/lib/jquery-rjs/rendering.rb:8:in `render_with_update'
/var/www/miq/vmdb/app/views/container_group/show.html.haml:12:in `_app_views_container_group_show_html_haml___1651958662836235636_152602360'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/template.rb:145:in `block in render'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/notifications.rb:166:in `instrument'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/template.rb:333:in `instrument'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/template.rb:143:in `render'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/renderer/template_renderer.rb:54:in `block (2 levels) in render_template'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/renderer/abstract_renderer.rb:39:in `block in instrument'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/notifications.rb:164:in `block in instrument'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/notifications/instrumenter.rb:20:in `instrument'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/notifications.rb:164:in `instrument'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/renderer/abstract_renderer.rb:39:in `instrument'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/renderer/template_renderer.rb:53:in `block in render_template'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/renderer/template_renderer.rb:61:in `render_with_layout'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/renderer/template_renderer.rb:52:in `render_template'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/renderer/template_renderer.rb:14:in `render'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/renderer/renderer.rb:42:in `render_template'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/renderer/renderer.rb:23:in `render'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/rendering.rb:100:in `_render_template'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/streaming.rb:217:in `_render_template'
/opt/rh/cfme-gemset/gems/actionview-4.2.5/lib/action_view/rendering.rb:83:in `render_to_body'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/rendering.rb:32:in `render_to_body'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/renderers.rb:37:in `render_to_body'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/abstract_controller/rendering.rb:25:in `render'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/rendering.rb:16:in `render'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/instrumentation.rb:44:in `block (2 levels) in render'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/core_ext/benchmark.rb:12:in `block in ms'
/opt/rh/rh-ruby22/root/usr/share/ruby/benchmark.rb:303:in `realtime'
/opt/rh/cfme-gemset/gems/activesupport-4.2.5/lib/active_support/core_ext/benchmark.rb:12:in `ms'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/instrumentation.rb:44:in `block in render'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/instrumentation.rb:87:in `cleanup_view_runtime'
/opt/rh/cfme-gemset/gems/activerecord-4.2.5/lib/active_record/railties/controller_runtime.rb:25:in `cleanup_view_runtime'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/instrumentation.rb:43:in `render'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/implicit_render.rb:10:in `default_render'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/implicit_render.rb:5:in `send_action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/abstract_controller/base.rb:198:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.5/lib/action_controller/metal/rendering.rb:10:in `process_action'




Version-Release number of selected component (if applicable):
----------------------
5.5.0.12


How reproducible:
----------------
Always


Steps to Reproduce:
------------------
1.Navigate to the summary page of a pod.
2.In the Relationships section,click Services.


Actual results:
---------------
UI error


Expected results:
-----------------
No errors


Additional info:
---------------

Comment 2 Federico Simoncelli 2015-12-03 16:39:24 UTC
I think this was introduced in:

https://github.com/ManageIQ/manageiq/pull/5029

--- a/app/views/container_group/show.html.haml
+++ b/app/views/container_group/show.html.haml
@@ -1,6 +1,4 @@
-- if %w(containers container_projects).include?(@display)
-    = render :partial => "layouts/gtl", :locals => {:action_url => "show/#{@record.id}"}
-- elsif @display == 'container_services' && @showtype != "compare"
+- if %w(containers).include?(@display)

Comment 3 Federico Simoncelli 2015-12-08 12:20:18 UTC
*** Bug 1289429 has been marked as a duplicate of this bug. ***

Comment 4 Daniel Korn 2015-12-08 14:12:38 UTC
proposed fix: https://github.com/ManageIQ/manageiq/pull/5750

Comment 6 Lucy Bopf 2016-05-17 05:12:32 UTC
It appears that this bug should no longer be documented as a known issue (and the requires_doc_text flag has been set to '-'). Removing doc text as well.

Comment 8 errata-xmlrpc 2016-06-29 15:14:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348


Note You need to log in before you can comment on or make changes to this bug.