Bug 1288060 - glusterd: disable ping timer b/w glusterd and make epoll thread count default 1
glusterd: disable ping timer b/w glusterd and make epoll thread count default 1
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
3.7.0
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Gaurav Kumar Garg
glusterd
:
Depends On: 1262236 1271750 1288059
Blocks: 1251815 1271749 1272436
  Show dependency treegraph
 
Reported: 2015-12-03 07:16 EST by Gaurav Kumar Garg
Modified: 2016-06-05 19:38 EDT (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1288059
Environment:
Last Closed: 2016-02-14 09:43:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gaurav Kumar Garg 2015-12-03 07:16:38 EST
+++ This bug was initially created as a clone of Bug #1288059 +++

+++ This bug was initially created as a clone of Bug #1271750 +++

+++ This bug was initially created as a clone of Bug #1262236 +++

Description of problem:

Currently glusterd is crashing when enable/disable heal and i/o is in progress on the fuse mount.
 

 


It seems to happen because of multi epoll thread between glusterd enable.

workaround is to make epoll thread to 1 and set ping-timeout to 0

--- Additional comment from Vijay Bellur on 2015-12-03 07:15:04 EST ---

REVIEW: http://review.gluster.org/12874 (glusterd: disable ping timer b/w glusterd and make epoll thread count to 1) posted (#1) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)
Comment 1 Vijay Bellur 2015-12-03 07:18:18 EST
REVIEW: http://review.gluster.org/12875 (glusterd: disable ping timer b/w glusterd and make epoll thread count to 1) posted (#1) for review on release-3.7 by Gaurav Kumar Garg (ggarg@redhat.com)
Comment 2 Vijay Bellur 2015-12-03 14:22:38 EST
COMMIT: http://review.gluster.org/12875 committed in release-3.7 by Vijay Bellur (vbellur@redhat.com) 
------
commit 49a40cb3b9a776b6c69a57e557a6fb80f7ac3a40
Author: Gaurav Kumar Garg <garg.gaurav52@gmail.com>
Date:   Thu Dec 3 17:41:13 2015 +0530

    glusterd: disable ping timer b/w glusterd and make epoll thread count to 1
    
    This patch is backport of: http://review.gluster.org/#/c/12874/
    
    Currently glusterd is crashing when enable/disable heal and i/o is in
    progress on the fuse mount.
    
    This is because of by default multi thread epoll in glusterd is 2.
    Workaround is to make epoll thread to 1 and set ping-timeout to 0
    
      >> Change-Id: Ifbe9b43a361c5409b707539f0ee831c610a5c36b
      >> BUG: 1288059
      >> Signed-off-by: Gaurav Kumar Garg <ggarg@redhat.com>
    
    Change-Id: Ifbe9b43a361c5409b707539f0ee831c610a5c36b
    BUG: 1288060
    Signed-off-by: Gaurav Kumar Garg <ggarg@redhat.com>
    Reviewed-on: http://review.gluster.org/12875
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 3 Gaurav Kumar Garg 2016-02-14 09:43:42 EST
GlusterFS v3.7.8 contains a fix for this bug. closing this bug.
Comment 4 Kaushal 2016-04-19 03:50:07 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.