Bug 1300411 - Cannot select required drop downs form service dialog
Cannot select required drop downs form service dialog
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
All All
high Severity urgent
: GA
: 5.6.0
Assigned To: Drew Bomhof
Niyaz Akhtar Ansari
:
Depends On: 1328049
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-20 12:30 EST by Kevin Morey
Modified: 2016-09-09 01:27 EDT (History)
12 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Previously, when using a service dialog with require fields, when selecting a field the previous field was being refreshed, even if you tell the dialog not to refresh the other fields. This fix changes a call to selectpicker that attempted to refresh all the dynamic dropdowns via classname and now only updates for the correct dom id which has now resolved the issue.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 11:31:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshots (288.11 KB, application/pdf)
2016-01-20 12:30 EST, Kevin Morey
no flags Details
service dialog to validate against (5.74 KB, text/x-vhdl)
2016-01-20 12:31 EST, Kevin Morey
no flags Details
Hotfix: dialog_field_refresh.js (4.22 KB, text/plain)
2016-01-21 09:40 EST, Drew Bomhof
no flags Details

  None (edit)
Description Kevin Morey 2016-01-20 12:30:36 EST
Created attachment 1116704 [details]
screenshots

Description of problem:
When using a service dialog with require fields, it seems as though each time you select a field the previous field is being refreshed even if you tell the dialog not to refresh the other fields.

Version-Release number of selected component (if applicable):
5.5.2.1

How reproducible:
100%

Steps to Reproduce:
1. Import attached dialog and connect it to a a button or catalog item
2. choose the first drop down
2. then choose the second field


Actual results:
the previous fields are auto refreshed.

Expected results:
fields should be selectable and not auto refresh other elements in the dialog without explicitly telling the dialog.

Additional info:
The only way i can work around this right now is to set all fields to not be mandatory (sorry for the double negative) :-)
Comment 2 Kevin Morey 2016-01-20 12:31 EST
Created attachment 1116706 [details]
service dialog to validate against
Comment 4 Greg McCullough 2016-01-20 14:59:06 EST
Drew - We validate this issue as part of the work on Bug 1289643.
Comment 6 CFME Bot 2016-01-21 09:22:43 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=2f4b46ed4b6b54fa3b44fec8ed02e56c291f8218

commit 2f4b46ed4b6b54fa3b44fec8ed02e56c291f8218
Merge: a1e9578 0557daa
Author:     Greg McCullough <gmccullo@redhat.com>
AuthorDate: Thu Jan 21 09:17:32 2016 -0500
Commit:     Greg McCullough <gmccullo@redhat.com>
CommitDate: Thu Jan 21 09:17:32 2016 -0500

    Merge branch 'resolve_select_picker_issues' into '5.5.z'
    
    Resolve inconsistent dialog auto refresh
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1289643
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1300411
    
    Change a call to selectpicker that
    attempted to refresh all the dynamic
    dropdowns via classname and now
    only update for the correct dom id.
    
    See merge request !740

 app/assets/javascripts/dialog_field_refresh.js | 4 +++-
 spec/javascripts/dialog_field_refresh_spec.js  | 5 +++++
 2 files changed, 8 insertions(+), 1 deletion(-)
Comment 7 CFME Bot 2016-01-21 09:22:54 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=0557daa87748cd125c46c9dbaf159e91fae534f9

commit 0557daa87748cd125c46c9dbaf159e91fae534f9
Author:     Drew Bomhof <dbomhof@redhat.com>
AuthorDate: Wed Jan 20 16:44:00 2016 -0500
Commit:     Drew Bomhof <dbomhof@redhat.com>
CommitDate: Wed Jan 20 16:44:00 2016 -0500

    Resolve inconsistent dialog auto refresh
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1289643
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1300411
    
    Change a call to selectpicker that
    attempted to refresh all the dynamic
    dropdowns via classname and now
    only update for the correct dom id.

 app/assets/javascripts/dialog_field_refresh.js | 4 +++-
 spec/javascripts/dialog_field_refresh_spec.js  | 5 +++++
 2 files changed, 8 insertions(+), 1 deletion(-)
Comment 8 Drew Bomhof 2016-01-21 09:40 EST
Created attachment 1116953 [details]
Hotfix: dialog_field_refresh.js

Please replace dialog_field_refresh.js with this attached Hotfix.

Path:  app/assets/javascripts/dialog_field_refresh.js
Comment 10 CFME Bot 2016-01-21 11:32:05 EST
Detected commit referencing this ticket while ticket status is MODIFIED.
Comment 15 CFME Bot 2016-01-22 16:30:55 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/93d7c815a256c259db91863b6f646644b65d1428

commit 93d7c815a256c259db91863b6f646644b65d1428
Author:     Drew Bomhof <dbomhof@redhat.com>
AuthorDate: Wed Jan 20 16:44:00 2016 -0500
Commit:     Drew Bomhof <dbomhof@redhat.com>
CommitDate: Thu Jan 21 10:04:26 2016 -0500

    Resolve inconsistent dialog auto refresh
    
    Change a call to selectpicker that
    attempted to refresh all the dynamic
    dropdowns via classname and now
    only update for the correct dom id.
    Resolves issues found in the following
    two BZ's
    https://bugzilla.redhat.com/show_bug.cgi?id=1289643
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1300411

 app/assets/javascripts/dialog_field_refresh.js | 2 +-
 spec/javascripts/dialog_field_refresh_spec.js  | 5 +++++
 2 files changed, 6 insertions(+), 1 deletion(-)
Comment 20 Niyaz Akhtar Ansari 2016-04-25 03:05:06 EDT
fields is selectable  and not auto refresh form service Catalogs is successful  

Verified in version: 5.6.0.4-beta2.3.20160421172650_719e256
Comment 22 errata-xmlrpc 2016-06-29 11:31:55 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.