Bug 1289960 - Running update on an updated overcloud (7.1 -> 7.2) fails
Running update on an updated overcloud (7.1 -> 7.2) fails
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity urgent
: ---
: 7.0 (Kilo)
Assigned To: chris alfonso
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-09 07:21 EST by Marius Cornea
Modified: 2016-04-18 03:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-09 19:00:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
deployment error (10.72 KB, text/plain)
2015-12-09 07:21 EST, Marius Cornea
no flags Details
/var/log/messages (17.72 MB, text/plain)
2015-12-09 07:46 EST, Marius Cornea
no flags Details
os-collect-config (4.60 MB, text/x-vhdl)
2015-12-09 07:47 EST, Marius Cornea
no flags Details

  None (edit)
Description Marius Cornea 2015-12-09 07:21:25 EST
Created attachment 1103850 [details]
deployment error

Description of problem:
Running update on an updated overcloud (7.1 -> 7.2) fails and ends up in an non working overcloud. 

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-0.8.6-87.el7ost.noarch patched with
https://bugzilla.redhat.com/show_bug.cgi?id=1289097#c3
https://bugzilla.redhat.com/show_bug.cgi?id=1289769#c7

How reproducible:
100%

Steps to Reproduce:
1. Deploy 7.1 environment 
2. Update 7.1 environment to 7.2 according to the procudure ( both undercloud and overcloud)
3. Make sure the update completes ok
4. Make a change to the heat templates. For instance I changed the neutron_admin_auth_url in puppet/controller-puppet.yaml from ':35357/v2.0' to ':35357' 

Actual results:
Update fails.

Expected results:
Updates completes ok and puppet is run with the new configuration.

Additional info:
Attaching the deployment error log.
Comment 1 Marius Cornea 2015-12-09 07:46 EST
Created attachment 1103873 [details]
/var/log/messages
Comment 2 Marius Cornea 2015-12-09 07:47 EST
Created attachment 1103874 [details]
os-collect-config

Note You need to log in before you can comment on or make changes to this bug.