Bug 1290350 - [User portal] No error message while leaving 'username:' and 'password:' fields blank
[User portal] No error message while leaving 'username:' and 'password:' fiel...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.UserPortal (Show other bugs)
3.6.1.1
Unspecified Linux
high Severity medium (vote)
: ovirt-3.6.3
: 3.6.3
Assigned To: Alexander Wels
Petr Matyáš
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-10 05:06 EST by Krishna Babu K
Modified: 2016-02-18 06:07 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-18 06:07:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: UX
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.z+
mgoldboi: planning_ack+
ecohen: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
screen shot to refer the 'both the fields empty' scenario (236.66 KB, image/png)
2015-12-10 05:06 EST, Krishna Babu K
no flags Details
screen shot to refer the 'one field empty' scenario (237.22 KB, image/png)
2015-12-10 05:08 EST, Krishna Babu K
no flags Details
screenshot (60.25 KB, image/png)
2016-01-21 06:18 EST, Petr Matyáš
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 51816 ovirt-engine-3.6 MERGED userportal: show fill in fields message 2016-01-18 10:55 EST
oVirt gerrit 52564 ovirt-engine-3.6.2 MERGED userportal: show fill in fields message 2016-01-24 04:26 EST

  None (edit)
Description Krishna Babu K 2015-12-10 05:06:29 EST
Created attachment 1104292 [details]
screen shot to refer the 'both the fields empty' scenario

Description of problem:

At userportal login page if user do not provide any credentials in 'username:' and 'password:' fields no error message is showing up, just an empty red square box pops up with error sign in it. It is applicable even when we leave one of those fields empty.

Version-Release number of selected component (if applicable):

3.6.1.1-0.1.el6

How reproducible:

Always

Steps to Reproduce:
1. Go to userportal login page.
2. Leave both 'username:' and 'password:' fields or one of them empty.
3. Click on login.

Actual results:

No error message

Expected results:

error message should be present, some thing like "Please fill in all fields"

Additional info:
screenshot attached for reference.
Comment 1 Krishna Babu K 2015-12-10 05:08 EST
Created attachment 1104293 [details]
screen shot to refer the 'one field empty' scenario
Comment 2 Einav Cohen 2015-12-15 08:33:57 EST
we have already fixed the issue for empty password (see bug 1254940 and bug 1251003), however this is probably fixed only for non-empty user-name.
need to make sure that the solution implemented for bug 1254940 and bug 1251003 applies for an 'empty-user-name and empty-password' situation as well. 

(consult with Greg, assignee of bug 1254940 and bug 1251003, if necessary)
Comment 3 Einav Cohen 2015-12-15 13:39:36 EST
(In reply to Einav Cohen from comment #2)
> this is probably fixed only for non-empty user-name.

another possibility is that this issue was fixed somehow only for the web-admin login page and not the user-portal login page. 

unrelated note: in 4.0, there are no user portal login page and web-admin login page - only SSO login page. 

So for 4.0 - please ensure that an appropriate error message appears for the SSO login page. 
for 3.6 - need a completely different patch that ensures that an appropriate error message appears for the web-admin and user-portal login pages.
Comment 4 Red Hat Bugzilla Rules Engine 2016-01-20 06:39:27 EST
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.
Comment 5 Red Hat Bugzilla Rules Engine 2016-01-20 06:40:54 EST
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.
Comment 6 Petr Matyáš 2016-01-21 06:18 EST
Created attachment 1116899 [details]
screenshot

There still isn't any message, just red squares.

Tested on 3.6.2-10
Comment 7 Alexander Wels 2016-01-21 08:51:47 EST
So it appears the patch didn't get backported to the 3.6.2 branch, just 3.6. I will backport it to 3.6.2
Comment 8 Red Hat Bugzilla Rules Engine 2016-01-21 18:03:45 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 9 Petr Matyáš 2016-01-29 07:10:27 EST
Verified on 3.6.3-1

Note You need to log in before you can comment on or make changes to this bug.