Bug 1290604 - S30Samba scripts do not work on systemd systems
S30Samba scripts do not work on systemd systems
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: gluster-smb (Show other bugs)
mainline
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Michael Adam
: Triaged
Depends On:
Blocks: 1292755 1292762 1292773
  Show dependency treegraph
 
Reported: 2015-12-10 18:41 EST by Michael Adam
Modified: 2016-06-16 09:50 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1292755 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:50:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Adam 2015-12-10 18:41:28 EST
Description of problem:

S30Samba hook scripts use /etc/init.d/smb .
But /etc/init.d/smb does not exist on systemd systems.
Using "service smb <COMMAND>" is the portable way.
It calls init scripts on sysv systems, and redirects
to systemctl on systemd systems.


Actual results:

scripts do not (re)start samba

Expected results:

scripts (re)start samba
Comment 1 Vijay Bellur 2015-12-10 18:42:24 EST
REVIEW: http://review.gluster.org/12945 (hook-scripts: fix S30Samba scripts on systemd systems) posted (#1) for review on master by Michael Adam (obnox@samba.org)
Comment 2 Vijay Bellur 2015-12-17 07:11:40 EST
COMMIT: http://review.gluster.org/12945 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit ce3ff7e328483dffdae6ae2914924bc2380db67e
Author: Michael Adam <obnox@samba.org>
Date:   Fri Dec 11 00:37:13 2015 +0100

    hook-scripts: fix S30Samba scripts on systemd systems
    
    /etc/init.d/smb does not exist on systemd systems.
    Using "service smb <COMMAND>" is the portable way.
    It calls init scripts on sysv systems, and redirects
    to systemctl on systemd systems.
    
    Change-Id: I7146c9998a51d8b170d3321f3477e92704ae7615
    BUG: 1290604
    Signed-off-by: Michael Adam <obnox@samba.org>
    Reviewed-on: http://review.gluster.org/12945
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anoop C S <anoopcs@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
Comment 3 Niels de Vos 2016-06-16 09:50:01 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.