Bug 1292773 - (RHEL6) S30Samba scripts do not work on systemd systems
(RHEL6) S30Samba scripts do not work on systemd systems
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: samba (Show other bugs)
3.1
Unspecified Unspecified
medium Severity medium
: ---
: RHGS 3.1.2
Assigned To: Michael Adam
Vivek Das
: Triaged, ZStream
Depends On: 1290604 1292755 1292762
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-18 05:13 EST by Michael Adam
Modified: 2016-03-01 01:04 EST (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5-13
Doc Type: Bug Fix
Doc Text:
Previously, the Samba hook scripts were explicitly calling SysV-init scripts for Samba /etc/init.d/smb. Due to this, the scripts did not work as expected on systemd systems and failed to restart or reload Samba when required. With this fix, the scripts now use the service command which works both on SysV and systemd systems.
Story Points: ---
Clone Of: 1292762
Environment:
Last Closed: 2016-03-01 01:04:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Michael Adam 2015-12-18 05:15:12 EST
cloned for RHEL6 to stay consistent.
(Strictly needed only for RHEL7).
Comment 4 rjoseph 2015-12-19 00:23:22 EST
Upstream Master: http://review.gluster.org/12945 
Upstream Release 3.7: http://review.gluster.org/13000
Downstream : https://code.engineering.redhat.com/gerrit/#/c/64209/
Comment 6 surabhi 2015-12-29 06:14:07 EST
Please add fixed in version.
Comment 7 Vivek Das 2015-12-30 06:26:45 EST
Ran this test and verified hook-scripts fix S30Samba scripts on systemd systems (RHEL6).
Did a service smb condrestart and it does start the smb service successfully.

Versions:
glusterfs-cli-3.7.5-13.el7rhgs.x86_64
samba-client-4.2.4-12.el7rhgs.x86_64
Comment 9 errata-xmlrpc 2016-03-01 01:04:35 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html

Note You need to log in before you can comment on or make changes to this bug.