Bug 1292755 - S30Samba scripts do not work on systemd systems
Summary: S30Samba scripts do not work on systemd systems
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: gluster-smb
Version: 3.7.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Michael Adam
QA Contact:
URL:
Whiteboard:
Depends On: 1290604
Blocks: 1292762 1292773
TreeView+ depends on / blocked
 
Reported: 2015-12-18 09:47 UTC by Michael Adam
Modified: 2016-04-19 07:51 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Clone Of: 1290604
: 1292762 (view as bug list)
Environment:
Last Closed: 2016-04-19 07:51:26 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Michael Adam 2015-12-18 09:47:51 UTC
+++ This bug was initially created as a clone of Bug #1290604 +++

Description of problem:

S30Samba hook scripts use /etc/init.d/smb .
But /etc/init.d/smb does not exist on systemd systems.
Using "service smb <COMMAND>" is the portable way.
It calls init scripts on sysv systems, and redirects
to systemctl on systemd systems.


Actual results:

scripts do not (re)start samba

Expected results:

scripts (re)start samba

--- Additional comment from Vijay Bellur on 2015-12-10 18:42:24 EST ---

REVIEW: http://review.gluster.org/12945 (hook-scripts: fix S30Samba scripts on systemd systems) posted (#1) for review on master by Michael Adam (obnox@samba.org)

--- Additional comment from Vijay Bellur on 2015-12-17 07:11:40 EST ---

COMMIT: http://review.gluster.org/12945 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit ce3ff7e328483dffdae6ae2914924bc2380db67e
Author: Michael Adam <obnox@samba.org>
Date:   Fri Dec 11 00:37:13 2015 +0100

    hook-scripts: fix S30Samba scripts on systemd systems
    
    /etc/init.d/smb does not exist on systemd systems.
    Using "service smb <COMMAND>" is the portable way.
    It calls init scripts on sysv systems, and redirects
    to systemctl on systemd systems.
    
    Change-Id: I7146c9998a51d8b170d3321f3477e92704ae7615
    BUG: 1290604
    Signed-off-by: Michael Adam <obnox@samba.org>
    Reviewed-on: http://review.gluster.org/12945
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anoop C S <anoopcs@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>

Comment 1 Vijay Bellur 2015-12-18 09:51:07 UTC
REVIEW: http://review.gluster.org/13000 (hook-scripts: fix S30Samba scripts on systemd systems) posted (#1) for review on release-3.7 by Michael Adam (obnox@samba.org)

Comment 2 Vijay Bellur 2015-12-19 05:05:03 UTC
COMMIT: http://review.gluster.org/13000 committed in release-3.7 by Rajesh Joseph (rjoseph@redhat.com) 
------
commit 66078a41a96fa3d00d226e3aaf7ec17c2deda953
Author: Michael Adam <obnox@samba.org>
Date:   Fri Dec 11 00:37:13 2015 +0100

    hook-scripts: fix S30Samba scripts on systemd systems
    
    /etc/init.d/smb does not exist on systemd systems.
    Using "service smb <COMMAND>" is the portable way.
    It calls init scripts on sysv systems, and redirects
    to systemctl on systemd systems.
    
    > Change-Id: I7146c9998a51d8b170d3321f3477e92704ae7615
    > BUG: 1290604
    > Signed-off-by: Michael Adam <obnox@samba.org>
    > Reviewed-on: http://review.gluster.org/12945
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Reviewed-by: Anoop C S <anoopcs@redhat.com>
    > Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: Niels de Vos <ndevos@redhat.com>
    
    (cherry picked from commit ce3ff7e328483dffdae6ae2914924bc2380db67e)
    
    Change-Id: Ied6b5fe330f8d29df10a9aea1809be5c5f0c8a5e
    BUG: 1292755
    Signed-off-by: Michael Adam <obnox@samba.org>
    Reviewed-on: http://review.gluster.org/13000
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>

Comment 3 Kaushal 2016-04-19 07:51:26 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.