Bug 1291083 - [hosted-engine] - Adjust management network settings when deployed over VLAN interface/s
Summary: [hosted-engine] - Adjust management network settings when deployed over VLAN ...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: Network
Version: 1.3.1.2
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ovirt-3.6.3
: 1.3.3.3
Assignee: Simone Tiraboschi
QA Contact: Michael Burman
URL:
Whiteboard:
: 1303931 1317541 (view as bug list)
Depends On:
Blocks: 1134346 1305885
TreeView+ depends on / blocked
 
Reported: 2015-12-13 15:54 UTC by Michael Burman
Modified: 2016-03-14 14:03 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
hosted-engine-setup was setting the VLAN tag attribute of the logical network at cluster level but it was not effective; setting at top level fixes it. Enforcing also that NetworkManager is off and that the hostname effectively resolves to the address used on the management network interface to provide a smooth experience.
Clone Of:
Environment:
Last Closed: 2016-03-11 07:23:45 UTC
oVirt Team: Integration
rule-engine: ovirt-3.6.z+
rule-engine: blocker+
ylavi: planning_ack+
sbonazzo: devel_ack+
gklein: testing_ack+


Attachments (Terms of Use)
screenshot (39.66 KB, image/png)
2015-12-13 15:54 UTC, Michael Burman
no flags Details
Logs (203.43 KB, application/x-gzip)
2015-12-14 06:06 UTC, Michael Burman
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1312663 unspecified CLOSED [hosted-engine] - Adjust management network settings when deployed over VLAN interface/s 2021-01-20 06:05:38 UTC
oVirt gerrit 53064 master MERGED networking: set VLAN on top level network object 2016-02-08 14:55:38 UTC
oVirt gerrit 53065 ovirt-hosted-engine-setup-1.3 MERGED networking: set VLAN on top level network object 2016-02-08 13:40:50 UTC
oVirt gerrit 53134 master MERGED network: enforce NetworkManager is not active 2016-02-05 16:06:00 UTC
oVirt gerrit 53142 master MERGED networking: enforcing unique match between hostname and mgmt interface 2016-02-08 13:12:54 UTC
oVirt gerrit 53201 ovirt-hosted-engine-setup-1.3 MERGED network: enforce NetworkManager is not active 2016-02-08 13:14:12 UTC
oVirt gerrit 53209 ovirt-hosted-engine-setup-1.3 MERGED networking: enforcing unique match between hostname and mgmt interface 2016-02-08 14:55:15 UTC
oVirt gerrit 53428 master MERGED network: fixing hostname - interface enforcing for DHCP setups 2016-02-16 09:33:09 UTC
oVirt gerrit 53434 ovirt-hosted-engine-setup-1.3 MERGED network: fixing hostname - interface enforcing for DHCP setups 2016-02-16 09:33:48 UTC

Internal Links: 1312663

Description Michael Burman 2015-12-13 15:54:44 UTC
Created attachment 1105350 [details]
screenshot

Description of problem:
[hosted-engine] - Adjust management network settings when deployed over VLAN interface/s

When self hosted engine is being deployed over VLAN it leads to situation that the management network is out-of-sync with host. Host is UP in engine. 

It is caused by engine-setup deploying engine with management network which does not have VLAN tag by default

Self hosted engine should take care of this in the final configuration stage.

WA - edit the management network with vlan tag via the Networks main tab.

Version-Release number of selected component (if applicable):
3.6.1.2-0.1.el6
ovirt-hosted-engine-setup-1.3.1.2-1.el7ev.noarch
vdsm-4.17.13-1.el7ev.noarch

How reproducible:
100

Steps to Reproduce:
1. Configure VLAN tagged interface on physical host
2. Run hosted-engine --deploy 
3. Choose the VLAN interface to be used for the management network deployment
4. Finish the hosted engine deplyoment

Actual results:
Host is out-of-sync with host. There is a difference between host(vlan) and DC(no vlan)

Expected results:
Management network should be synced to host after deployment is done.
Self hosted engine should take care of this in the final configuration stage.

Additional info:
It's a regression bug. This was fixed and verified on 3.5.z - BZ 1124207

Comment 1 Michael Burman 2015-12-14 06:06:55 UTC
Created attachment 1105476 [details]
Logs

Comment 2 Red Hat Bugzilla Rules Engine 2015-12-16 21:40:09 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 3 Simone Tiraboschi 2016-02-03 17:24:08 UTC
*** Bug 1303931 has been marked as a duplicate of this bug. ***

Comment 4 Simone Tiraboschi 2016-02-11 14:23:45 UTC
It fails with VLAN and DHCP; moving back to assigned.

Comment 5 Red Hat Bugzilla Rules Engine 2016-02-11 14:23:46 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 6 Michael Burman 2016-02-23 09:41:47 UTC
Verified on - ovirt-hosted-engine-setup-1.3.3.3-1.el7ev.noarch

Both with rhel 7.2 and rhev-h 7.2 20160222.0.el7ev 
with:
rhevm-appliance-20160212.0-1
engine-3.6.3.1-0.1.el6
vdsm-4.17.21-0.el7ev

Tested over vlan NIC and vlan BOND with success

Comment 7 Yedidyah Bar David 2016-03-14 14:03:32 UTC
*** Bug 1317541 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.