Bug 1291854 - Searching on Host vmm_vendor in the UI brings back no records
Searching on Host vmm_vendor in the UI brings back no records
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Reporting (Show other bugs)
5.4.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Tim Wade
Kyrylo Zvyagintsev
:
Depends On:
Blocks: 1291880 1291881
  Show dependency treegraph
 
Reported: 2015-12-15 12:50 EST by Dan Clarizio
Modified: 2016-06-29 11:20 EDT (History)
4 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1291880 1291881 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:20:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Clarizio 2015-12-15 12:50:07 EST
Description of problem:
Using the OOTB Host searches or creating new ones that use vmm_vendor in the search criteria brings back no records.

Version-Release number of selected component (if applicable):
5.4

How reproducible:
Click on one of the OOTB VMware ESX version filters

Actual results:
No records found

Expected results:
Matching records should be displayed

Additional info:
Research shows that the vmm_vendor method returns a cased string like "VMware" where the DB vmm_vendor column has "vmware" in it.  The vmm_vendor method may need to be defined as a virtual column so the search code handles this difference properly.
Comment 3 Tim Wade 2016-01-15 18:29:34 EST
PR: https://github.com/ManageIQ/manageiq/pull/6207
Comment 6 errata-xmlrpc 2016-06-29 11:20:48 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.