Bug 1291856 - When aborting due to large distribution, Erlang does not produce a crash dump
When aborting due to large distribution, Erlang does not produce a crash dump
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: erlang (Show other bugs)
6.0 (Juno)
Unspecified Unspecified
high Severity unspecified
: ---
: 6.0 (Juno)
Assigned To: John Eckersberg
Udi
: ZStream
Depends On: 1291822
Blocks: 1291855
  Show dependency treegraph
 
Reported: 2015-12-15 12:51 EST by John Eckersberg
Modified: 2016-06-08 08:09 EDT (History)
9 users (show)

See Also:
Fixed In Version: erlang-R16B-03.7min.3.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1291822
Environment:
Last Closed: 2016-06-08 08:09:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Eckersberg 2015-12-15 12:51:40 EST
+++ This bug was initially created as a clone of Bug #1291822 +++

Erlang aborts in dist_port_command with ERTS_ABORT_EXIT:

    if (size > (Uint) INT_MAX)
	erl_exit(ERTS_ABORT_EXIT,
		 "Absurdly large distribution output data buffer "
		 "(%beu bytes) passed.\n",
		 size);

However, ERTS_ABORT_EXIT inhibits erlang crash dump generation.  It would be better to exit with ERTS_DUMP_EXIT so a crash dump is generated, in order to help debug crashes from large messages.
Comment 3 Udi 2016-05-30 04:57:03 EDT
Verified in Juno 2016-05-04 with erlang-R16B-03.7min.3.el7ost.x86_64, using the explosivo.sh script from bug #1291822.
Comment 5 errata-xmlrpc 2016-06-08 08:09:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1211

Note You need to log in before you can comment on or make changes to this bug.