Bug 1291855 - When aborting due to large distribution, Erlang does not produce a crash dump
When aborting due to large distribution, Erlang does not produce a crash dump
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: erlang (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity unspecified
: z4
: 7.0 (Kilo)
Assigned To: John Eckersberg
Udi
: ZStream
Depends On: 1291822 1291856 1291857
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-15 12:50 EST by John Eckersberg
Modified: 2016-02-18 11:10 EST (History)
8 users (show)

See Also:
Fixed In Version: erlang-R16B-03.10min.4.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1291822
Environment:
Last Closed: 2016-02-18 11:10:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Eckersberg 2015-12-15 12:50:46 EST
+++ This bug was initially created as a clone of Bug #1291822 +++

Erlang aborts in dist_port_command with ERTS_ABORT_EXIT:

    if (size > (Uint) INT_MAX)
	erl_exit(ERTS_ABORT_EXIT,
		 "Absurdly large distribution output data buffer "
		 "(%beu bytes) passed.\n",
		 size);

However, ERTS_ABORT_EXIT inhibits erlang crash dump generation.  It would be better to exit with ERTS_DUMP_EXIT so a crash dump is generated, in order to help debug crashes from large messages.
Comment 2 Udi 2016-01-19 05:47:38 EST
I will need more info. Where in openstack is erlang used and where do I find the code lines that you mention? Do you have a scenario to recreate this large buffer?
Comment 3 John Eckersberg 2016-01-19 09:12:39 EST
(In reply to Udi from comment #2)
> I will need more info. Where in openstack is erlang used and where do I find
> the code lines that you mention? Do you have a scenario to recreate this
> large buffer?

See https://bugzilla.redhat.com/show_bug.cgi?id=1291822#c4 from the original bug
Comment 4 Udi 2016-01-20 12:50:22 EST
Verified with the images that are shipped with 7.3.
Comment 7 errata-xmlrpc 2016-02-18 11:10:16 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0259.html

Note You need to log in before you can comment on or make changes to this bug.