Bug 1291822 - When aborting due to large distribution, Erlang does not produce a crash dump
When aborting due to large distribution, Erlang does not produce a crash dump
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: erlang (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
high Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: John Eckersberg
Udi
:
Depends On:
Blocks: 1291855 1291856 1291857
  Show dependency treegraph
 
Reported: 2015-12-15 11:18 EST by John Eckersberg
Modified: 2016-04-07 17:18 EDT (History)
10 users (show)

See Also:
Fixed In Version: erlang-R16B-03.10min.4.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1291855 1291856 1291857 (view as bug list)
Environment:
Last Closed: 2016-04-07 17:18:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Eckersberg 2015-12-15 11:18:39 EST
Erlang aborts in dist_port_command with ERTS_ABORT_EXIT:

    if (size > (Uint) INT_MAX)
	erl_exit(ERTS_ABORT_EXIT,
		 "Absurdly large distribution output data buffer "
		 "(%beu bytes) passed.\n",
		 size);

However, ERTS_ABORT_EXIT inhibits erlang crash dump generation.  It would be better to exit with ERTS_DUMP_EXIT so a crash dump is generated, in order to help debug crashes from large messages.
Comment 5 Udi 2016-01-20 12:49:38 EST
Verified with the images that are shipped with 8.0 beta.
Comment 6 errata-xmlrpc 2016-04-07 17:18:40 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.