Bug 1291857 - When aborting due to large distribution, Erlang does not produce a crash dump
When aborting due to large distribution, Erlang does not produce a crash dump
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: erlang (Show other bugs)
5.0 (RHEL 7)
Unspecified Unspecified
high Severity unspecified
: async
: 5.0 (RHEL 7)
Assigned To: John Eckersberg
nlevinki
: ZStream
Depends On: 1291822
Blocks: 1262455 1291855
  Show dependency treegraph
 
Reported: 2015-12-15 12:51 EST by John Eckersberg
Modified: 2016-02-11 08:44 EST (History)
10 users (show)

See Also:
Fixed In Version: erlang-R16B-03.7min.3.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1291822
Environment:
Last Closed: 2016-02-11 08:44:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Eckersberg 2015-12-15 12:51:58 EST
+++ This bug was initially created as a clone of Bug #1291822 +++

Erlang aborts in dist_port_command with ERTS_ABORT_EXIT:

    if (size > (Uint) INT_MAX)
	erl_exit(ERTS_ABORT_EXIT,
		 "Absurdly large distribution output data buffer "
		 "(%beu bytes) passed.\n",
		 size);

However, ERTS_ABORT_EXIT inhibits erlang crash dump generation.  It would be better to exit with ERTS_DUMP_EXIT so a crash dump is generated, in order to help debug crashes from large messages.
Comment 4 errata-xmlrpc 2016-02-11 08:44:07 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0167.html

Note You need to log in before you can comment on or make changes to this bug.