Bug 1293034 - Creation of files on hot tier volume taking very long time
Creation of files on hot tier volume taking very long time
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: bugs@gluster.org
bugs@gluster.org
: ZStream
Depends On: 1282729 1319696 1319698 1377864
Blocks: 1260783 1293659
  Show dependency treegraph
 
Reported: 2015-12-19 08:33 EST by Joseph Elwin Fernandes
Modified: 2016-09-20 16:24 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1282729
: 1293659 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:51:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-19 08:33:37 EST
REVIEW: http://review.gluster.org/12972 (ctr/sql: providing for cache size and wal checkpoint and file path not recorded) posted (#13) for review on master by Joseph Fernandes
Comment 2 Vijay Bellur 2015-12-21 11:34:32 EST
REVIEW: http://review.gluster.org/12972 (ctr/sql: providing for cache size and wal checkpoint and file path not recorded) posted (#14) for review on master by Joseph Fernandes
Comment 3 Vijay Bellur 2015-12-21 12:44:54 EST
REVIEW: http://review.gluster.org/12972 (ctr/sql: providing for cache size and wal checkpoint and file path not recorded) posted (#15) for review on master by Joseph Fernandes
Comment 4 Vijay Bellur 2015-12-21 13:34:42 EST
REVIEW: http://review.gluster.org/12972 (ctr/sql: providing for cache size and wal checkpoint and file path not recorded) posted (#16) for review on master by Joseph Fernandes
Comment 5 Vijay Bellur 2015-12-21 13:57:48 EST
REVIEW: http://review.gluster.org/12972 (ctr/sql: providing for cache size and wal checkpoint and file path not recorded) posted (#17) for review on master by Joseph Fernandes
Comment 6 Vijay Bellur 2015-12-21 20:33:06 EST
REVIEW: http://review.gluster.org/12972 (ctr/sql: Providing for vol set for sqlcachesize and sqlWALsize and skip recording path) posted (#18) for review on master by Joseph Fernandes
Comment 7 Vijay Bellur 2015-12-22 02:45:13 EST
REVIEW: http://review.gluster.org/12972 (ctr/sql: Providing for vol set for sqlcachesize and sqlWALsize and skip recording path) posted (#19) for review on master by Joseph Fernandes
Comment 8 Vijay Bellur 2015-12-22 10:14:13 EST
COMMIT: http://review.gluster.org/12972 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit 439de31320315872d988720991e9baaead8712db
Author: Joseph Fernandes <josferna@redhat.com>
Date:   Tue Dec 15 18:29:06 2015 +0530

    ctr/sql: Providing for vol set for sqlcachesize and sqlWALsize and skip recording path
    
    1. Providing vol set option for cache size and wal autocheck point
       so that performance can be tuned.
    2. Removed recording of file path in the db. Trimming database columns.
       Path need not be stored in the db, as PARGFID, GFID, Basename is suffice
       to derive the path during migration.
    
    Change-Id: I2cb590451a6d244bc91fe66c6dbffe2c2059dfb8
    BUG: 1293034
    Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    Reviewed-on: http://review.gluster.org/12972
    Reviewed-by: N Balachandran <nbalacha@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 9 Niels de Vos 2016-06-16 09:51:17 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.