Bug 1293659 - Creation of files on hot tier volume taking very long time
Creation of files on hot tier volume taking very long time
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.6
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: bugs@gluster.org
bugs@gluster.org
: ZStream
Depends On: 1282729 1293034 1319696 1319698 1377864
Blocks: 1260783
  Show dependency treegraph
 
Reported: 2015-12-22 10:40 EST by Joseph Elwin Fernandes
Modified: 2016-09-20 16:24 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1293034
Environment:
Last Closed: 2016-04-19 03:51:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-22 10:43:00 EST
REVIEW: http://review.gluster.org/13067 (ctr/sql: Providing for vol set for sqlcachesize and sqlWALsize and skip recording path) posted (#1) for review on release-3.7 by Joseph Fernandes
Comment 2 Vijay Bellur 2015-12-22 17:45:23 EST
COMMIT: http://review.gluster.org/13067 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit a7de0cd095f799e3128f74fcccc57ac4d6fd0b6d
Author: Joseph Fernandes <josferna@redhat.com>
Date:   Tue Dec 15 18:29:06 2015 +0530

    ctr/sql: Providing for vol set for sqlcachesize and sqlWALsize and skip recording path
    
    1. Providing vol set option for cache size and wal autocheck point
       so that performance can be tuned.
    2. Removed recording of file path in the db. Trimming database columns.
       Path need not be stored in the db, as PARGFID, GFID, Basename is suffice
       to derive the path during migration.
    
    Backport of http://review.gluster.org/12972
    
    > Change-Id: I2cb590451a6d244bc91fe66c6dbffe2c2059dfb8
    > BUG: 1293034
    > Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    > Reviewed-on: http://review.gluster.org/12972
    > Reviewed-by: N Balachandran <nbalacha@redhat.com>
    > Tested-by: Gluster Build System <jenkins@build.gluster.com>
    > Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    > Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    > Tested-by: Dan Lambright <dlambrig@redhat.com>
    Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    
    Change-Id: Ia1c109983ec6ce75ed27b8c08f454f5b6283c31d
    BUG: 1293659
    Reviewed-on: http://review.gluster.org/13067
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 3 Kaushal 2016-04-19 03:51:49 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.