Bug 1293253 - Admin guide: Changes needed in configuring CTDB section in admin guide
Admin guide: Changes needed in configuring CTDB section in admin guide
Status: CLOSED CURRENTRELEASE
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: Documentation (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity urgent
: ---
: RHGS 3.1.2
Assigned To: Bhavana
surabhi
: Documentation, ZStream
Depends On:
Blocks: 1298830
  Show dependency treegraph
 
Reported: 2015-12-21 03:50 EST by surabhi
Modified: 2017-11-17 00:31 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description surabhi 2015-12-21 03:50:13 EST
Document URL:
https://access.redhat.com/documentation/en-US/Red_Hat_Storage/3.1/html/Administration_Guide/sect-SMB.html#idp14861056

Section Number and Name: 
7.3.1 : Sub-heading : Configuring CTDB on Red Hat Gluster Storage Server 

Bullet 3 : Start the volume. 

Describe the issue: 

Currently the points which are mentioned in start of the volume changes with the fix for bug 1292751, so following changes are required in the above mentioned section of the Admin guide:

Current:
*********************************************************
 The S29CTDBsetup.sh script runs on all Red Hat Gluster Storage servers and adds the following lines to the [global] section of your Samba configuration file at /etc/samba/smb.conf.

clustering = yes
idmap backend = tdb2

The script stops Samba server, modifies Samba configuration, adds an entry in /etc/fstab/ for the mount, and mounts the volume at /gluster/lock on all the nodes with Samba server. It also enables automatic start of CTDB service on reboot.

Note
When you stop the special CTDB volume, the S29CTDB-teardown.sh script runs on all Red Hat Gluster Storage servers and removes the following lines from [global] section of your Samba configuration file at /etc/samba/smb.conf.

clustering = yes
 idmap backend = tdb2

It also removes an entry in /etc/fstab/ for the mount and unmounts the volume at /gluster/lock. 

************************************************************

Suggestions for improvement: 

***************************************************

It should be as follows:


 The S29CTDBsetup.sh script runs on all Red Hat Gluster Storage servers, adds an entry in /etc/fstab/ for the mount, and mounts the volume at /gluster/lock on all the nodes with Samba server. It also enables automatic start of CTDB service on reboot.

Note
When you stop the special CTDB volume, the S29CTDB-teardown.sh script runs on all Red Hat Gluster Storage servers and removes an entry in /etc/fstab/ for the mount and unmounts the volume at /gluster/lock. 


Additional information:
Comment 2 Michael Adam 2015-12-21 15:46:54 EST
This bug is automatically being proposed for the current z-stream release of Red Hat Gluster Storage 3 by setting the release flag 'rhgs‑3.1.z' to '?'. 

If this bug should be proposed for a different release, please manually change the proposed release flag.
Comment 3 Michael Adam 2015-12-21 15:50:04 EST
This is due to the S29CTDB* hook scripts being changed (fixed) in RHGS 3.1.2 to not touch smb.conf. [A Samba installation is either clusterd or not clustered, that does not change due to a lock volume being available or not...]

We should possibly also add a note to the section on configuring Samba, that the admin needs to put 'clustering = yes' into smb.conf before starting ctdb and leave it there.

(We could also put this into the rhs-smb.conf snipped shipped with our samba packages...)
Comment 4 Michael Adam 2015-12-21 15:50:31 EST
(In reply to Michael Adam from comment #2)
> This bug is automatically being proposed for the current z-stream release of
> Red Hat Gluster Storage 3 by setting the release flag 'rhgs‑3.1.z' to '?'. 
> 
> If this bug should be proposed for a different release, please manually
> change the proposed release flag.

ignore this -- copy'n'paste error ... :-/
Comment 5 surabhi 2015-12-23 07:13:19 EST
https://access.redhat.com/documentation/en-US/Red_Hat_Storage/3.1/html/Administration_Guide/sect-SMB.html

7.3.1:
Setting up CTDB for Samba 

Prerequisites section:
yum install ctdb2.5 should be changed to yum install ctdb
Comment 8 surabhi 2016-01-14 08:18:04 EST
1. Add clustering =yes to be added manually before ctdb start.

2. ctdb service start should be added just after ctdb config.
Comment 9 surabhi 2016-01-14 08:49:40 EST
In section 7.3 SMB :

In warning section have to add one more point :

The CTDB version 2.5 is being deprecated from Red Hat Gluster Storage 3.1 Update 2 release. Further updates will not be provided for ctdb2.x. You must upgrade the system to ctdb-4.x, which is provided in a separate channel or repository, for all updates including the security updates. For more information regarding the installation and upgrade steps refer the Red Hat Gluster Storage 3.1 Installation Guide. 

Michael, could you review this and provide your inputs for this.
Comment 10 surabhi 2016-01-15 03:29:48 EST
Just a small correction :


The CTDB version 2.5 is being deprecated from Red Hat Gluster Storage 3.1 Update 2 release. Further updates will not be provided for ctdb2.x. You must upgrade the system to ctdb-4.x, which is provided in samba channel, for all updates including the security updates. For more information regarding the installation and upgrade steps refer the Red Hat Gluster Storage 3.1 Installation Guide.
Comment 11 surabhi 2016-01-15 03:31:17 EST
Also just before yum install ctdb add a note that :

Ensure that you are subscribed to samba channel to get latest ctdb packages.
Comment 12 Michael Adam 2016-01-18 02:13:06 EST
(In reply to surabhi from comment #10)
> Just a small correction :
> 
> 
> The CTDB version 2.5 is being deprecated from Red Hat Gluster Storage 3.1
> Update 2 release. 

Maybe omit ' release' ?

> Further updates will not be provided for ctdb2.x.

> You must
> upgrade the system to ctdb-4.x, which is provided in samba channel, for all
> updates including the security updates.

Possibly reverse the order for increased clarity:

"For all updates including security updates, you must upgrade ..."

> For more information regarding the
> installation and upgrade steps refer the Red Hat Gluster Storage 3.1

refer +to the ...

> Installation Guide.


The question is how strong a statement we want to make:

The above reads as if a customer can continue using ctdb 2.5, but
should install ctdb from the samba channels in  order to receive
further updates.

A slightly stronger statement might be similar to this:

CTDB version 2.5 is being deprecated from Red Hat Gluster Storage 3.1 Update 2 and is not supported any more. Further updates will not be provided for ctdb2.5.
Starting with RHGS 3.1.2, the CTDB software is provided by the Samba channel.
In order to use CTDB in RHGS 3.1.2 and newer, you must install CTDB  4.x from the samba-channel. ...

Not 100% sure what our position is, here. I would prefer a stronger variant.
Comment 13 Michael Adam 2016-01-18 02:17:49 EST
Bug #1298830 is the counterpart of this BZ for the installation guide. They should be in sync.
Comment 14 Michael Adam 2016-01-18 02:18:55 EST
Bug #1298893 treats correspondong changes to the RHGS lifecycle page. I think the wordings should be sync'd.
Comment 15 Bhavana 2016-01-18 06:15:48 EST
Hi Surabhi,

Have added the "warning" and made the other changes based on your comments and our discussions with Raghavendra.

http://jenkinscat.gsslab.pnq.redhat.com:8080/job/doc-Red_Hat_Gluster_Storage-3.1-Administration_Guide%20%28html-single%29/lastStableBuild/artifact/tmp/en-US/html-single/index.html#sect-SMB
Comment 16 surabhi 2016-01-18 08:31:00 EST
Hi Bhavana,

The note should be above the yum install ctdb command.

Rest look fine.
Comment 17 Michael Adam 2016-01-18 12:09:00 EST
"... must upgrade the system to CTDB 4.x, which is provided in a separate channel or repository."

I think that 'in a separate channel or repository.' sounds very mysterious.
Can we name it as the samba-channel?
Comment 19 Michael Adam 2016-01-19 01:47:21 EST
Looks good to me, thanks!
Comment 20 surabhi 2016-01-25 01:25:30 EST
All changes are made and the doc looks fine. Moving the BZ to verified.

Note You need to log in before you can comment on or make changes to this bug.