Bug 1293380 - [tiering]: Tiering isn't started after attaching hot tier and hence no promotion/demotion
[tiering]: Tiering isn't started after attaching hot tier and hence no promot...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: quota (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity high
: ---
: RHGS 3.1.2
Assigned To: Sankarshan Mukhopadhyay
krishnaram Karthick
: ZStream
Depends On:
Blocks: 1294637 1296040
  Show dependency treegraph
 
Reported: 2015-12-21 10:43 EST by krishnaram Karthick
Modified: 2016-09-17 08:35 EDT (History)
11 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5-15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1294637 (view as bug list)
Environment:
Last Closed: 2016-03-01 01:05:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 4 Vijaikumar Mallikarjuna 2015-12-29 07:09:26 EST
Patch submitted upstream: http://review.gluster.org/#/c/13110/
Comment 6 Vijaikumar Mallikarjuna 2016-01-07 06:37:52 EST
upstream patch: http://review.gluster.org/#/c/13110/
release-3.7 patch: http://review.gluster.org/#/c/13182/
downstream patch: https://code.engineering.redhat.com/gerrit/65064
Comment 7 krishnaram Karthick 2016-01-11 00:27:26 EST
Verified the fix with build glusterfs-3.7.5-15.el7rhgs.x86_64

Following steps were followed to verify on distributed and EC volume

1) Create a volume
2) enabled quota
3) Create multiple sub-directories on the volume and set quota for each sub-directory
3) Attached hot tier
4) Check if tiering process has started
5) Repeat the test 5 times

Moving the bug to verified state.
Comment 10 errata-xmlrpc 2016-03-01 01:05:12 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html

Note You need to log in before you can comment on or make changes to this bug.