Bug 1294637 - [tiering]: Tiering isn't started after attaching hot tier and hence no promotion/demotion
[tiering]: Tiering isn't started after attaching hot tier and hence no promot...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Manikandan
: ZStream
Depends On: 1293380
Blocks: 1296040
  Show dependency treegraph
 
Reported: 2015-12-29 07:03 EST by Vijaikumar Mallikarjuna
Modified: 2016-06-16 09:52 EDT (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1293380
: 1296040 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:52:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-29 07:08:16 EST
REVIEW: http://review.gluster.org/13110 (quota: fix quota hook script for add-brick) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 2 Vijay Bellur 2015-12-30 01:15:51 EST
REVIEW: http://review.gluster.org/13110 (quota: fix quota hook script for add-brick) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 3 Vijay Bellur 2016-01-05 01:17:00 EST
REVIEW: http://review.gluster.org/13110 (quota: fix quota hook script for add-brick) posted (#3) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 4 Vijay Bellur 2016-01-05 02:22:13 EST
REVIEW: http://review.gluster.org/13110 (quota: fix quota hook script for add-brick) posted (#4) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 5 Vijay Bellur 2016-01-05 07:29:01 EST
REVIEW: http://review.gluster.org/13110 (quota: fix quota hook script for add-brick) posted (#5) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 6 Vijay Bellur 2016-01-06 04:09:45 EST
REVIEW: http://review.gluster.org/13110 (quota: fix quota hook script for add-brick) posted (#6) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 7 Vijay Bellur 2016-01-06 04:25:25 EST
REVIEW: http://review.gluster.org/13110 (quota: fix quota hook script for add-brick) posted (#7) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 8 Vijay Bellur 2016-01-19 03:22:22 EST
REVIEW: http://review.gluster.org/13110 (quota: fix quota hook script for add-brick) posted (#8) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 9 Vijay Bellur 2016-02-01 00:50:29 EST
REVIEW: http://review.gluster.org/13110 (quota: fix quota hook script for add-brick) posted (#9) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 10 Vijay Bellur 2016-02-05 01:45:33 EST
REVIEW: http://review.gluster.org/13110 (quota: fix quota hook script for add-brick) posted (#10) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 11 Vijay Bellur 2016-02-05 01:50:36 EST
REVIEW: http://review.gluster.org/13110 (quota: fix quota hook script for add-brick) posted (#11) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 12 Vijay Bellur 2016-02-08 22:59:00 EST
COMMIT: http://review.gluster.org/13110 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 6608b5cc1f9d01261b767c3abae212c6222e6ba6
Author: vmallika <vmallika@redhat.com>
Date:   Tue Dec 29 17:35:30 2015 +0530

    quota: fix quota hook script for add-brick
    
    Hook script should not call any CLI commands
    as this can cause parallel operation problem,
    so remove quota list command from the script
    
    Change-Id: I76a364133403371b172e063abd5f742075b20a2f
    BUG: 1294637
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/13110
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 15 Niels de Vos 2016-06-16 09:52:41 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.