Bug 1296040 - [tiering]: Tiering isn't started after attaching hot tier and hence no promotion/demotion
[tiering]: Tiering isn't started after attaching hot tier and hence no promot...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
3.7.5
Unspecified Unspecified
unspecified Severity high
: 3.7.5
: ---
Assigned To: Vijaikumar Mallikarjuna
: ZStream
Depends On: 1293380 1294637
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-06 04:11 EST by Vijaikumar Mallikarjuna
Modified: 2016-05-11 18:49 EDT (History)
10 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1294637
Environment:
Last Closed: 2016-04-19 03:25:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-01-06 04:12:37 EST
REVIEW: http://review.gluster.org/13182 (quota: fix quota hook script for add-brick) posted (#1) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 2 Vijay Bellur 2016-01-06 04:24:52 EST
REVIEW: http://review.gluster.org/13182 (quota: fix quota hook script for add-brick) posted (#2) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 3 Vijay Bellur 2016-01-06 06:53:24 EST
REVIEW: http://review.gluster.org/13182 (quota: fix quota hook script for add-brick) posted (#3) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 4 Vijay Bellur 2016-01-19 03:34:08 EST
REVIEW: http://review.gluster.org/13182 (quota: fix quota hook script for add-brick) posted (#4) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 5 Vijay Bellur 2016-01-22 06:30:26 EST
REVIEW: http://review.gluster.org/13182 (quota: fix quota hook script for add-brick) posted (#5) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 6 Vijay Bellur 2016-01-27 01:25:47 EST
REVIEW: http://review.gluster.org/13182 (quota: fix quota hook script for add-brick) posted (#6) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 7 Vijay Bellur 2016-02-01 00:52:59 EST
REVIEW: http://review.gluster.org/13182 (quota: fix quota hook script for add-brick) posted (#7) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 8 Vijay Bellur 2016-02-08 02:09:50 EST
REVIEW: http://review.gluster.org/13182 (quota: fix quota hook script for add-brick) posted (#8) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 9 Vijay Bellur 2016-02-09 07:28:00 EST
REVIEW: http://review.gluster.org/13182 (quota: fix quota hook script for add-brick) posted (#9) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 10 Vijay Bellur 2016-02-10 03:58:37 EST
COMMIT: http://review.gluster.org/13182 committed in release-3.7 by Atin Mukherjee (amukherj@redhat.com) 
------
commit 4ebe6c4df3415bfad6cb5bc29a9aa2eb53fdb6c3
Author: vmallika <vmallika@redhat.com>
Date:   Tue Dec 29 17:35:30 2015 +0530

    quota: fix quota hook script for add-brick
    
    This is a backport of http://review.gluster.org/#/c/13110/
    
    Hook script should not call any CLI commands
    as this can cause parallel operation problem,
    so remove quota list command from the script
    
    > Change-Id: I76a364133403371b172e063abd5f742075b20a2f
    > BUG: 1294637
    >Signed-off-by: vmallika <vmallika@redhat.com>
    
    Change-Id: I9f2850e53c2ce69b33a82acec3fc739bc5bf54e5
    BUG: 1296040
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/13182
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 11 Kaushal 2016-04-19 03:25:49 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.