Bug 1293408 - Overcloud nodes are created without swap space
Overcloud nodes are created without swap space
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
7.0 (Kilo)
All All
medium Severity high
: beta
: 11.0 (Ocata)
Assigned To: Hugh Brock
Raviv Bar-Tal
: Triaged
: 1425164 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-21 12:11 EST by Dan Yocum
Modified: 2018-03-06 05:52 EST (History)
9 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-6.0.0-1.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-05-17 15:25:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2148341 None None None 2018-03-06 05:52 EST
OpenStack gerrit 418273 None None None 2017-02-06 18:58 EST

  None (edit)
Description Dan Yocum 2015-12-21 12:11:49 EST
Description of problem:
overcloud compute nodes are created w/o swap space

Version-Release number of selected component (if applicable):
7.1

How reproducible:
every

Steps to Reproduce:
1. deploy overcloud
2. no swap
3.

Actual results:
no swap

Expected results:
a "reasonable" amount of swap created

Additional info:
Comment 3 Mike Burns 2016-04-07 17:00:12 EDT
This bug did not make the OSP 8.0 release.  It is being deferred to OSP 10.
Comment 5 Alex Schultz 2017-02-06 18:58:15 EST
As of 10, we support the ability to deploy with swap. (Was fixed in Bug 1415103)

1. Prepare for swap.yaml.
$ cat swap.yaml
resource_registry:
  OS::TripleO::AllNodesExtraConfig: extraconfig/all_nodes/swap.yaml
parameter_defaults:
  swap_size_megabytes: '2048'
  swap_path: '/swap'

2. Deploy with the swap.yaml.
openstack overcloud deploy -e swap.yaml


Additionally, we will be providing a basic out of the box environment file for either swap files or swap partitions in openstack-tripleo-heat-templates such that a user can just add '-e /usr/share/openstack-tripleo-heat-templates/environments/enable-swap.yaml' or '-e /usr/share/openstack-tripleo-heat-templates/environments/enable-swap-partition.yaml'
Comment 6 Irina Petrova 2017-02-21 04:52:27 EST
*** Bug 1425164 has been marked as a duplicate of this bug. ***
Comment 10 errata-xmlrpc 2017-05-17 15:25:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245

Note You need to log in before you can comment on or make changes to this bug.