Bug 1293601 - quota: handle quota xattr removal when quota is enabled again
quota: handle quota xattr removal when quota is enabled again
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Manikandan
:
Depends On:
Blocks: 1294609 1294642
  Show dependency treegraph
 
Reported: 2015-12-22 05:59 EST by Vijaikumar Mallikarjuna
Modified: 2016-06-16 09:51 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1294609 1294642 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:51:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaikumar Mallikarjuna 2015-12-22 05:59:28 EST
When a quota is disable and enabled again before completing
the cleanup operation, this can remove the new xattrs
and quota accounting can become wrong

Remove removing the xattr, check if quota enabled again and the
xattr is new
Comment 1 Vijay Bellur 2015-12-22 06:07:42 EST
REVIEW: http://review.gluster.org/13065 (quota: handle quota xattr removal when quota is enabled again) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 2 Vijay Bellur 2015-12-22 06:09:48 EST
REVIEW: http://review.gluster.org/13065 (quota: handle quota xattr removal when quota is enabled again) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 3 Vijay Bellur 2015-12-28 07:17:28 EST
REVIEW: http://review.gluster.org/13065 (quota: handle quota xattr removal when quota is enabled again) posted (#3) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 4 Vijay Bellur 2016-01-06 06:55:04 EST
REVIEW: http://review.gluster.org/13065 (quota: handle quota xattr removal when quota is enabled again) posted (#4) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 5 Vijay Bellur 2016-01-07 03:20:15 EST
REVIEW: http://review.gluster.org/13065 (quota: handle quota xattr removal when quota is enabled again) posted (#5) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 6 Vijay Bellur 2016-01-07 03:20:31 EST
COMMIT: http://review.gluster.org/13065 committed in master by Raghavendra G (rgowdapp@redhat.com) 
------
commit 33ca7a7384491bf78f1c905a9085c17415eb1d91
Author: vmallika <vmallika@redhat.com>
Date:   Tue Dec 22 16:32:49 2015 +0530

    quota: handle quota xattr removal when quota is enabled again
    
    When a quota is disable and enabled again before completing
    the cleanup operation, this can remove the new xattrs
    and quota accounting can become wrong
    
    Remove removing the xattr, check if quota enabled again and the
    xattr is new
    
    Change-Id: Idda216f1e7346a9b843dbc112ea3e6faa9c47483
    BUG: 1293601
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/13065
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    Tested-by: Raghavendra G <rgowdapp@redhat.com>
Comment 9 Niels de Vos 2016-06-16 09:51:54 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.