Bug 1294609 - quota: handle quota xattr removal when quota is enabled again
quota: handle quota xattr removal when quota is enabled again
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
3.7.5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vijaikumar Mallikarjuna
:
Depends On: 1293601 1294642
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-29 04:15 EST by Vijaikumar Mallikarjuna
Modified: 2016-05-11 18:49 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1293601
Environment:
Last Closed: 2016-04-19 03:52:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaikumar Mallikarjuna 2015-12-29 04:15:43 EST
+++ This bug was initially created as a clone of Bug #1293601 +++

When a quota is disable and enabled again before completing
the cleanup operation, this can remove the new xattrs
and quota accounting can become wrong

Remove removing the xattr, check if quota enabled again and the
xattr is new

--- Additional comment from Vijay Bellur on 2015-12-22 06:07:42 EST ---

REVIEW: http://review.gluster.org/13065 (quota: handle quota xattr removal when quota is enabled again) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

--- Additional comment from Vijay Bellur on 2015-12-22 06:09:48 EST ---

REVIEW: http://review.gluster.org/13065 (quota: handle quota xattr removal when quota is enabled again) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

--- Additional comment from Vijay Bellur on 2015-12-28 07:17:28 EST ---

REVIEW: http://review.gluster.org/13065 (quota: handle quota xattr removal when quota is enabled again) posted (#3) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 1 Vijay Bellur 2015-12-29 04:16:11 EST
REVIEW: http://review.gluster.org/13109 (quota: handle quota xattr removal when quota is enabled again) posted (#1) for review on release-3.7 by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 2 Vijay Bellur 2016-01-07 03:20:48 EST
COMMIT: http://review.gluster.org/13109 committed in release-3.7 by Raghavendra G (rgowdapp@redhat.com) 
------
commit 124eac4e46cb52e4dc7e47ce4e01adddc4ff44fd
Author: vmallika <vmallika@redhat.com>
Date:   Tue Dec 22 16:32:49 2015 +0530

    quota: handle quota xattr removal when quota is enabled again
    
    This is a backport of http://review.gluster.org/#/c/13065/
    
    When a quota is disable and enabled again before completing
    the cleanup operation, this can remove the new xattrs
    and quota accounting can become wrong
    
    Remove removing the xattr, check if quota enabled again and the
    xattr is new
    
    > Change-Id: Idda216f1e7346a9b843dbc112ea3e6faa9c47483
    > BUG: 1293601
    > Signed-off-by: vmallika <vmallika@redhat.com>
    
    Change-Id: Ia9e3002229427f811d6a35eabf21541f4fa057af
    BUG: 1294609
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/13109
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 3 Kaushal 2016-04-19 03:52:20 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.