Bug 1294642 - quota: handle quota xattr removal when quota is enabled again
quota: handle quota xattr removal when quota is enabled again
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: quota (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: RHGS 3.1.3
Assigned To: Manikandan
Anil Shah
: ZStream
Depends On: 1293601
Blocks: 1294609 1299184
  Show dependency treegraph
 
Reported: 2015-12-29 07:18 EST by Vijaikumar Mallikarjuna
Modified: 2016-09-17 08:42 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.7.9-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1293601
Environment:
Last Closed: 2016-06-23 01:00:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaikumar Mallikarjuna 2015-12-29 07:18:56 EST
+++ This bug was initially created as a clone of Bug #1293601 +++

When a quota is disable and enabled again before completing
the cleanup operation, this can remove the new xattrs
and quota accounting can become wrong

Remove removing the xattr, check if quota enabled again and the
xattr is new

--- Additional comment from Vijay Bellur on 2015-12-22 06:07:42 EST ---

REVIEW: http://review.gluster.org/13065 (quota: handle quota xattr removal when quota is enabled again) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

--- Additional comment from Vijay Bellur on 2015-12-22 06:09:48 EST ---

REVIEW: http://review.gluster.org/13065 (quota: handle quota xattr removal when quota is enabled again) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)

--- Additional comment from Vijay Bellur on 2015-12-28 07:17:28 EST ---

REVIEW: http://review.gluster.org/13065 (quota: handle quota xattr removal when quota is enabled again) posted (#3) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 1 Vijaikumar Mallikarjuna 2015-12-29 07:19:30 EST
Patch submitted upstream: http://review.gluster.org/13065
Comment 4 Mike McCune 2016-03-28 19:44:20 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 5 Vijaikumar Mallikarjuna 2016-04-06 23:02:26 EDT
Fix "http://review.gluster.org/13065" is available in 3.1.3 as part of rebase
Comment 7 Anil Shah 2016-05-10 09:47:35 EDT
Created 2*2 distributed replicate vol.
enabled quota and set limit usage
Mount on client and started IO
Enabled quota and disabled quota multiple times in loop
checked quota list


Bug verified on build glusterfs-3.7.9-4.el7rhgs.x86_64
Comment 11 errata-xmlrpc 2016-06-23 01:00:48 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1240

Note You need to log in before you can comment on or make changes to this bug.