Bug 1293652 - DNF: Unable to load repositories without updateinfo
DNF: Unable to load repositories without updateinfo
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-22 09:53 EST by Jan ONDREJ
Modified: 2016-01-06 04:57 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-06 04:57:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan ONDREJ 2015-12-22 09:53:12 EST
Description of problem:
Unable to load some repositories using dnf. For example epel repository has no working updateinfo, which fails to load it.

Version-Release number of selected component (if applicable):
dnf-1.1.4-2.fc23.noarch
dnf-1.1.5-1.fc23.noarch

How reproducible:
always

Steps to Reproduce:
cat > /etc/yum.repos.d/epel.repo << EOF
[epel]
name=epel
mirrorlist=http://mirrors.fedoraproject.org/metalink?repo=epel-7&arch=x86_64
EOF
dnf update

Actual results:
Failed to open: /var/cache/dnf/epel-a84ebc916ab68dc8/repodata/eb6509090a740d6ed73ee5e0ec9ecea05fbdcecbb7465ba62eaf0742c90c3360-updateinfo.xml.bz2.

Expected results:
no error

Additional info:
This bug mentions an non official repository, but I think this should fail with other repositories too. I an not sure, what exactly is wrong, but with more debugging I found, that this error message is confusing. This missing file exists on my system and is readable:

file /var/cache/dnf/epel-a84ebc916ab68dc8/repodata/eb6509090a740d6ed73ee5e0ec9ecea05fbdcecbb7465ba62eaf0742c90c3360-updateinfo.xml.bz2
/var/cache/dnf/epel-a84ebc916ab68dc8/repodata/eb6509090a740d6ed73ee5e0ec9ecea05fbdcecbb7465ba62eaf0742c90c3360-updateinfo.xml.bz2: bzip2 compressed data, block size = 500k

Looks like problem is with opening of solvx file, which is missing and this problem is misinterpreted as missing xml.bz2 file.

open("/var/cache/dnf/epel-updateinfo.solvx", O_RDONLY) = -1 ENOENT (No such file or directory)

Please, fix this bug. I use dnf for collecting data from various repositories and this way unable to use it. Thank you.
Comment 1 Honza Silhan 2015-12-23 08:07:12 EST

*** This bug has been marked as a duplicate of bug 1258416 ***
Comment 2 Honza Silhan 2015-12-23 08:09:44 EST
I am sorry not actually this dup but the new libsolv fixing this should be already in f23 stable repo: https://bodhi.fedoraproject.org/updates/FEDORA-2015-ef37719be7
Comment 3 Jan ONDREJ 2015-12-23 10:34:26 EST
(In reply to Jan Silhan from comment #2)
> I am sorry not actually this dup but the new libsolv fixing this should be
> already in f23 stable repo:
> https://bodhi.fedoraproject.org/updates/FEDORA-2015-ef37719be7

Not fixed by this update. Can you try to reproduce? It's easy to reproduce, you can remove epel.repo and no need to update anything, just run "dnf update" and do not confirm real update.

[root@localhost ~]# rpm -q dnf libsolv hawkey
dnf-1.1.5-1.fc23.noarch
libsolv-0.6.14-7.fc23.x86_64
hawkey-0.6.2-3.fc23.x86_64
[root@localhost ~]# dnf clean all
Cleaning repos: updates epel fedora
Cleaning up Everything
[root@localhost ~]# dnf update --disablerepo=* --enablerepo=epel
epel                                             15 MB/s | 9.4 MB     00:00    
Failed to open: /var/cache/dnf/epel-a84ebc916ab68dc8/repodata/eb6509090a740d6ed73ee5e0ec9ecea05fbdcecbb7465ba62eaf0742c90c3360-updateinfo.xml.bz2.
[root@localhost ~]# 

I temporarily fixed this in my scripts by setting load_updateinfo=False. Btw, can this option be configurable in dnf.base.Base class?
Comment 4 Jaroslav Mracek 2016-01-05 08:51:00 EST
The problem can be solved by installing libsolv for epel7 (http://koji.fedoraproject.org/koji/buildinfo?buildID=704417). We still don't know why version for 23 doesn't work correctly.
Comment 5 Jan ONDREJ 2016-01-05 12:05:41 EST
(In reply to Jaroslav Mracek from comment #4)
> The problem can be solved by installing libsolv for epel7
> don't know why version for 23 doesn't work correctly.

May be this is an different problem. Fedora has dnf-1, epel7 only dnf-0.6.
May be it's enough to fix this in dnf and skip loading of missing solvx files.
Can you try to debug this on Fedora? It's easy to reproduce using steps in this bug.

Btw, I can't reproduce this problem with libsolv-0.6.11-1.el7.x86_64. May be this is a different problem of dnf in Fedora 23.
Comment 6 Jaroslav Mracek 2016-01-06 03:58:56 EST
The problem will be fixed in next release

Note You need to log in before you can comment on or make changes to this bug.