Bug 1258416 - Cannot read EPEL metadata
Summary: Cannot read EPEL metadata
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libsolv
Version: rawhide
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1279648 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-08-31 10:42 UTC by RevRagnarok
Modified: 2016-11-18 21:41 UTC (History)
24 users (show)

Fixed In Version: libsolv-0.6.14-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-31 23:29:01 UTC
Type: Bug


Attachments (Terms of Use)
DNF log with python traceback (3.64 KB, text/plain)
2015-08-31 10:42 UTC, RevRagnarok
no flags Details
Patch to enable bzip2 support (1.22 KB, patch)
2015-09-09 20:16 UTC, Martin Sourada
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
CentOS 9339 0 None None None Never

Description RevRagnarok 2015-08-31 10:42:52 UTC
Created attachment 1068590 [details]
DNF log with python traceback

Description of problem:
Cannot run "dnf upgrade" on CentOS 7.1.1503

Version-Release number of selected component (if applicable):
[rr@embdev006 tmp]$ dnf --version
0.6.4
  Installed: dnf-0:0.6.4-2.el7.noarch at 2015-08-19 14:58
  Built    : Fedora Project at 2015-07-07 11:48

  Installed: rpm-0:4.11.1-25.el7.x86_64 at 2015-08-13 09:18
  Built    : CentOS BuildSystem <http://bugs.centos.org> at 2015-03-06 05:27


How reproducible:
Every time. 

Steps to Reproduce:
1. sudo dnf clean all
2. sudo rm -rf /var/cache/dnf/ /var/log/dnf.*
3. sudo dnf upgrade

Actual results:
[rr@embdev006 tmp]$ sudo dnf upgrade
Extra Packages for Enterprise Linux 7 - x86_64                                                                      636 kB/s | 9.0 MB     00:14    
Failed to open: /var/cache/dnf/x86_64/7/x86_64/7/epel/repodata/0eec099ba4d1cdc3bde47ad9ef9e718b8aad46ca7c09795ce4bd4f95123b95e7-updateinfo.xml.bz2.

Expected results:
Upgrade works.

Additional info:
"sudo yum clean all && sudo yum upgrade" on this machine can read EPEL's metadata file fine.

"bunzip2 -t 0eec099ba4d1cdc3bde47ad9ef9e718b8aad46ca7c09795ce4bd4f95123b95e7-updateinfo.xml.bz2" says downloaded file is valid.

Comment 1 Honza Silhan 2015-09-01 15:33:57 UTC
we should probably enable bunzip2 compression in libsolv.

Comment 3 Martin Sourada 2015-09-04 22:51:21 UTC
(In reply to Jan Silhan from comment #1)
> we should probably enable bunzip2 compression in libsolv.

Seems like this helps. Please update the package.

Comment 4 Martin Sourada 2015-09-09 20:16:38 UTC
Created attachment 1071905 [details]
Patch to enable bzip2 support

Comment 5 Honza Silhan 2015-11-18 13:31:48 UTC
*** Bug 1279648 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2015-12-09 16:23:06 UTC
libsolv-0.6.14-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-71b2d3fcdd

Comment 7 Fedora Update System 2015-12-10 11:21:53 UTC
libsolv-0.6.14-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update libsolv'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-71b2d3fcdd

Comment 8 dominix 2015-12-11 23:38:30 UTC
(In reply to Fedora Update System from comment #7)
> libsolv-0.6.14-1.el7 has been pushed to the Fedora EPEL 7 testing
> repository. If problems still persist, please make note of it in this bug
> report.
> If you want to test the update, you can install it with
> $ su -c 'yum --enablerepo=epel-testing update libsolv'
> You can provide feedback for this update here:
> https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-71b2d3fcdd

this solved the issue for me, thanks for notification.

Comment 9 Daniel Miranda 2015-12-16 11:00:42 UTC
Should this problem manifest itself on Fedora 22? When attempting to create an EPEL 7 chroot with mock I'm hit by what I believe is this bug:

$ mock --init -r epel-7-x86_64
INFO: mock.py version 1.2.13 starting (python version = 3.4.2)...
Start: init plugins
INFO: selinux enabled
Finish: init plugins
Start: run
Start: clean chroot
Finish: clean chroot
Start: chroot init
INFO: calling preinit hooks
INFO: enabled root cache
INFO: enabled dnf cache
Start: cleaning dnf metadata
Finish: cleaning dnf metadata
INFO: enabled ccache
Mock Version: 1.2.13
INFO: Mock Version: 1.2.13
Start: dnf install
Failed to open: /var/lib/mock/epel-7-x86_64/root/var/cache/dnf/epel-b7d9da81043aa7ab/repodata/fefdc467d54c3c7f6ddbb5abced77c7a80c79d854e6c0ad9b9e10131f5cac7db-updateinfo.xml.bz2.
ERROR: Command failed. See logs for output.
 # /usr/bin/dnf --installroot /var/lib/mock/epel-7-x86_64/root/ --releasever 7 --disableplugin=snapper install @buildsys-build --setopt=tsflags=nocontexts

Comment 10 Honza Silhan 2015-12-23 13:07:12 UTC
*** Bug 1293652 has been marked as a duplicate of this bug. ***

Comment 11 Fedora Update System 2015-12-31 23:28:56 UTC
libsolv-0.6.14-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Kevin Whalen 2016-05-11 20:55:26 UTC
Sometime during April 2016, 0.6.14 seems to have been dropped from EPEL 7 stable repository. Sometime been May 3rd and May 11th, 0.6.20 seems to have been dropped from EPEL 7 testing repository.

Comment 13 Andres Arenas 2016-06-02 18:20:27 UTC
AS Kevin says, is still missing. Nor libsolv-0.6.14-1.el7 or 0.6.20 can be found on any repo at this moment.

Comment 14 Yuri Arabadji 2016-06-03 11:54:15 UTC
Where do we send money to get this fixed?

Comment 15 Dennis M. Pöpperl 2016-06-15 18:39:16 UTC
When checking the package at https://admin.fedoraproject.org/pkgdb/package/rpms/libsolv/, the package status for EPEL 7 says "Retired". The only available version is currently 0.6.11-1.el7 from the CentOS Base repository. The last build for EPEL can be found at http://koji.fedoraproject.org/koji/buildinfo?buildID=704417. Installing this package directly from the there works. CentOS needs to update their package or backport the fix.

Comment 16 Theodor van Nahl 2016-06-17 08:42:13 UTC
The package has been changed from Approved to Retired on 2016-05-12 [0] but was unable to find any reasons for the change. I am using libsolv-0.6.20-1.el7.x86_64, which I had installed via EPEL 7 testing, on a server for months and I haven't had any problems. Am I missing a bugreport?

https://admin.fedoraproject.org/pkgdb/package/rpms/libsolv/timeline#n1

Comment 17 Igor Gnatenko 2016-06-17 08:44:41 UTC
This problem will be fixed in CentOS 6.3 and RHEL as well.

Comment 18 D. Hugh Redelmeier 2016-10-23 15:31:31 UTC
I am still experiencing this bug in CentOS 7.  Even after "yum update".

If I run "dnf update", I get:
Failed to open: /var/cache/dnf/x86_64/7/x86_64/7/epel/repodata/4604192be6a6b33d138dfce0a1ab49bc369a9bc1c5531d4ba2e1746b02e51131-updateinfo.xml.bz2.

I can fix this by "yum remove epel-release" but then I don't have epel.

I can re-add epel by "dnf install epel-release".  Unfortunately, dnf then fails again with the "Failed to open" message.

What's up?  Why is this still broken for me?  I don't think that I'm alone: http://unix.stackexchange.com/questions/250249/error-after-installing-dnf-on-centos-7

Comment 19 D. Hugh Redelmeier 2016-10-24 23:52:58 UTC
More information:

$ cat /etc/centos-release
CentOS Linux release 7.2.1511 (Core) 

$ sudo yum list libsolv
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: centos.mirror.netelligent.ca
 * epel: mirror.steadfast.net
 * extras: centos.mirror.netelligent.ca
 * updates: centos.mirror.netelligent.ca
Installed Packages
libsolv.x86_64   0.6.11-1.el7             @base
Available PackagES
libsolv.i686     0.6.11-1.el7             base 

This is an old version, without the fix.  Why is it still the latest in the standard CentOS 7 repos?

Is this the latest version in RHEL repos too?  Or is CentOS lagging?

If the problem is in both, then EPEL should include an updated version (to support dnf, which is in EPEL).

Comment 20 Letian Zhang 2016-10-29 13:24:57 UTC
libsolv is marked Retired for EPEL-7 and the reason might be "Already in RHEL" (you can see this by clicking the Retired text on the right from https://admin.fedoraproject.org/pkgdb/package/rpms/libsolv/). But the version from Centos-Base is 0.6.11 which is not compatible with dnf.

I installed a newer version from http://koji.fedoraproject.org/koji/buildinfo?buildID=758301 and it works.

Maybe the newer version need to be added back.

Comment 21 D. Hugh Redelmeier 2016-10-29 13:57:59 UTC
It also seems that the dnf packaging needs to specify that it depends on libsolv of at least version 0.6.x.  I don't know what x is, but it is greater than 11 and might be as large as 14.

Comment 22 James Kennedy 2016-11-18 21:41:24 UTC
libsolv needs to be re-added to EPEL7. EL7 does not provide a working package, and it should not have been removed.


Note You need to log in before you can comment on or make changes to this bug.