Bug 1294676 - rbovirt: sat6 times out when listing VMs in RHEV compute resource
rbovirt: sat6 times out when listing VMs in RHEV compute resource
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Compute Resources (Show other bugs)
6.1.5
All Linux
high Severity high (vote)
: Beta
: --
Assigned To: Tomer Brisker
Kedar Bidarkar
http://projects.theforeman.org/issues...
: PrioBumpPM, Triaged
Depends On: 1316802 1327336
Blocks: GSS_Sat6Beta_Tracker/GSS_Sat6_Tracker 1317530 1320314 1344527
  Show dependency treegraph
 
Reported: 2015-12-29 10:15 EST by Julio Entrena Perez
Modified: 2017-08-22 07:01 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1320314 1344527 (view as bug list)
Environment:
Last Closed: 2016-07-27 05:22:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2109411 None None None 2015-12-29 10:35 EST

  None (edit)
Description Julio Entrena Perez 2015-12-29 10:15:29 EST
Description of problem:
Timeout when trying to list the VMs in a RHEV compute resource.

Version-Release number of selected component (if applicable):
ruby193-rubygem-rbovirt-0.0.29-1.el7sat

How reproducible:
Always

Steps to Reproduce:
1. Add a RHEV compute resource with a large number of VMs
2. Try to view the list of VMs in the RHEV compute resource
3.

Actual results:
- Web ui displays "There was an error listing VMs: Request Timeout".

- /var/log/foreman/production.log shows the request is timing out after 60 seconds:

2015-12-29 09:29:00 [D] RestClient.get "https://rhevm.example.com/api/datacenters/f4f8fd40-452c-4042-8152-4d5dc84a764c", "Accept"=>"application/xml", "Accept-Encoding"=>"gzip, deflate", "Authorization"=>"Basic xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx", "Content-Type"=>"application/xml"

2015-12-29 09:29:00 [D] # => 200 OK | application/xml 379 bytes

2015-12-29 09:29:00 [D] RestClient.get "https://rhevm.example.com/api/vms?search=datacenter%3DRHEV-DC", "Accept"=>"application/xml; detail=disks; detail=nics; detail=hosts", "Accept-Encoding"=>"gzip, deflate", "Authorization"=>"Basic xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx", "Content-Type"=>"application/xml"

2015-12-29 09:30:01 [W] Error has occurred while listing VMs on RHEV-DC (RHEV): Request Timeout

Expected results:
The VMs are listed.

Additional info:
rbovirt seems to be inheriting the default timeout from Net::HTTP .
In file /usr/share/ruby/net/http.rb:

  630     # Creates a new Net::HTTP object for the specified server address,
  631     # without opening the TCP connection or initializing the HTTP session.
 
  633     def initialize(address, port = nil)

  645       @read_timeout = 60
Comment 3 Bryan Kearney 2016-01-08 11:18:21 EST
Created redmine issue http://projects.theforeman.org/issues/13091 from this bug
Comment 4 Lukas Zapletal 2016-03-09 05:54:30 EST
Related pull request in rbovirt: https://github.com/abenari/rbovirt/pull/102
Comment 5 Lukas Zapletal 2016-03-09 05:56:24 EST
Eric, this patch will need cherry-pick in both Foreman core and RbOvirt gem. Do you want me to clone the BZ for RbOvirt, or a message here is enough?
Comment 6 Lukas Zapletal 2016-03-09 10:16:11 EST
QA NOTE: Script to generate VMs: https://github.com/lzap/bin-public/blob/master/create-ovirt-vms
Comment 7 Eric Helms 2016-03-09 15:47:05 EST
Separate issue for the rbovirt update would be preferred for our tooling since it is designed to pickup atomic changes (and ideally changesets) which sometimes occur when Packaging issues are created in Redmine but are more rare.
Comment 8 Bryan Kearney 2016-03-13 08:13:06 EDT
Upstream bug assigned to tbrisker@redhat.com
Comment 9 Bryan Kearney 2016-03-18 06:12:59 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/13091 has been closed
-------------
Anonymous
Applied in changeset commit:fbd765f1a9430e51b64006b88c0773da0419c4d6.
Comment 12 Kedar Bidarkar 2016-04-20 06:15:43 EDT
a) Created a RHEV compute Resource by adding the above link.
b) Had selected a data center called "dc_scale_fake" which had 9.9k vm's
c) Moved to the VM's tab and listed the vm's, clicking the next button started showing up the new VM's.

VERIFIED with sat62-snap8.1
Comment 14 errata-xmlrpc 2016-07-27 05:22:03 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.