Bug 1294785 - [RFE] Include LBaaS v2 documentation in Kilo docs
[RFE] Include LBaaS v2 documentation in Kilo docs
Status: CLOSED CANTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
7.0 (Kilo)
All All
medium Severity medium
: ---
: 8.0 (Liberty)
Assigned To: RHOS Documentation Team
RHOS Documentation Team
: Documentation, FutureFeature, ZStream
: 1215470 1316356 (view as bug list)
Depends On:
Blocks: 1090733
  Show dependency treegraph
 
Reported: 2015-12-30 05:22 EST by Anand Nande
Modified: 2017-09-11 01:47 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-11 01:46:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anand Nande 2015-12-30 05:22:07 EST
Kilo documentation currently only includes instructions for configuring LBaaS v1: https://access.redhat.com/documentation/en/red-hat-enterprise-linux-openstack-platform/7/networking-guide/chapter-11-configure-load-balancing-as-a-service-lbaas

Should include steps to configure LBaaS v2 as well.

The steps can be based on : https://bugzilla.redhat.com/show_bug.cgi?id=1221021#c5
Comment 2 Lucy Bopf 2017-06-23 03:12:55 EDT
I'd like to first confirm how LBaaS v2 was implemented in RHEL OSP 7.

Nir, I see two bugs closed at WONTFIX:

https://bugzilla.redhat.com/show_bug.cgi?id=1221021#c24
https://bugzilla.redhat.com/show_bug.cgi?id=1235663#c28

Can you confirm whether the implementation of LBaaS v2 as suggested in https://bugzilla.redhat.com/show_bug.cgi?id=1221021#c5 is supported in 7 and should be documented?
Comment 3 Nir Yechiel 2017-06-24 23:32:48 EDT
(In reply to Lucy Bopf from comment #2)
> I'd like to first confirm how LBaaS v2 was implemented in RHEL OSP 7.
> 
> Nir, I see two bugs closed at WONTFIX:
> 
> https://bugzilla.redhat.com/show_bug.cgi?id=1221021#c24
> https://bugzilla.redhat.com/show_bug.cgi?id=1235663#c28
> 
> Can you confirm whether the implementation of LBaaS v2 as suggested in
> https://bugzilla.redhat.com/show_bug.cgi?id=1221021#c5 is supported in 7 and
> should be documented?

Hi Lucy,

Load Balancing as a Service (LBaaS) is packaged with RHOSP as it was started as an integral part of the Neutron tarball, together with an HAProxy based service plugin. 

The LBaaS v1 API was available to our customers since RHOSP 5, and LBaaS v2 is available starting with RHOSP 7 - but both lack proper deployment support and are not part of our HA reference architecture. 

These days, the LBaaS API is being moved into Octavia - a new LBaaS v2 open source reference implementation. The upstream community and the Octavia project are focused solely on the v2 API. In accordance with the upstream project, the v1 LBaaS API was deprecated with RHOSP 9 and removed with RHOSP 10. 

As of RHOSP 11 we still ship the v2 LBaaS API with an HAProxy based implementation, but this solution lacks deployment and HA support, and is no longer being maintained upstream. This means that RHOSP customers are really limited to using LBaaS with a commercial solution (LBaaS is part of the RHOSP certification program) and don’t have a decent out-of-the-box alternative.

We are working on productizing Octavia, with full support (including HA and TripleO/director integration) expected with RHOSP 13. See BZ #1433523.


Thanks,
Nir
Comment 4 Lucy Bopf 2017-09-11 01:35:33 EDT
*** Bug 1316356 has been marked as a duplicate of this bug. ***
Comment 5 Lucy Bopf 2017-09-11 01:46:24 EDT
I am closing this bug based on comment 3; unfortunately, there is no recommended solution for us to document for version 7. Both engineering and documentation resources are focused on upcoming versions, including, as Nir mentioned, a fully supported solution for LBaaS.
Comment 6 Lucy Bopf 2017-09-11 01:47:42 EDT
*** Bug 1215470 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.