Bug 1295809 - Require API to retrieve the osd utilization
Summary: Require API to retrieve the osd utilization
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Calamari
Version: 1.3.1
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 2.0
Assignee: Christina Meno
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
: 1295810 (view as bug list)
Depends On:
Blocks: 1291304
TreeView+ depends on / blocked
 
Reported: 2016-01-05 14:15 UTC by Nishanth Thomas
Modified: 2016-08-23 19:29 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-23 19:29:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1755 normal SHIPPED_LIVE Red Hat Ceph Storage 2.0 bug fix and enhancement update 2016-08-23 23:23:52 UTC

Description Nishanth Thomas 2016-01-05 14:15:11 UTC
Need an API to retrieve the total,used,free space of osds of a cluster

Comment 2 Federico Lucifredi 2016-01-06 17:00:17 UTC
Shouldn't this be rather implemented in 2.0? switching to that version.

Comment 4 Federico Lucifredi 2016-01-06 17:02:29 UTC
*** Bug 1295810 has been marked as a duplicate of this bug. ***

Comment 5 Nishanth Thomas 2016-01-27 19:07:18 UTC
Yes this should be implemented in 2.0 so that USM can consume

Comment 6 Christina Meno 2016-01-29 18:43:52 UTC
We don't have this in the data from ceph which looks like this:
"osd_metadata": [
        {
            "backend_filestore_partition_path": "unknown", 
            "backend_filestore_dev_node": "unknown", 
            "kernel_description": "#114-Ubuntu SMP Tue Dec 1 02:34:22 UTC 2015", 
            "distro_version": "14.04", 
            "back_addr": "104.236.159.39:6804/1002134", 
            "osd": 0, 
            "distro_codename": "trusty", 
            "hostname": "vagrant-ubuntu-trusty-64", 
            "mem_swap_kb": "0", 
            "id": 0, 
            "ceph_version": "ceph version 9.2.0 (bb2ecea240f3a1d525bcb35670cb07bd1f0ca299)", 
            "distro": "Ubuntu", 
            "hb_back_addr": "104.236.159.39:6805/1002134", 
            "osd_objectstore": "filestore", 
            "osd_data": "/var/lib/ceph/osd/ceph-0", 
            "arch": "x86_64", 
            "hb_front_addr": "104.236.159.39:6806/1002134", 
            "distro_description": "Ubuntu 14.04.3 LTS", 
            "filestore_backend": "generic", 
            "front_addr": "104.236.159.39:6800/2134", 
            "kernel_version": "3.13.0-71-generic", 
            "osd_journal": "/var/lib/ceph/osd/ceph-0/journal", 
            "filestore_f_type": "0xef53", 
            "mem_total_kb": "2049944", 
            "os": "Linux", 
            "cpu": "Intel(R) Xeon(R) CPU E5-2630L v2 @ 2.40GHz"
        }
    ], 



Either rhs-controller can schedule a utilization check with salt or Ceph needs to grown the capability first.

Comment 7 Dusmant 2016-02-02 08:51:56 UTC
Which one would be a better choice in your opinion?

Comment 8 Nishanth Thomas 2016-02-02 09:04:03 UTC
Can calamari use 'ceph osd df' command to get utilization from ceph and expose it through an API?. We expect per OSD based utilization data here

Comment 9 Christina Meno 2016-02-03 22:22:37 UTC
That is a possibility. It should take 2 days

Comment 10 Christina Meno 2016-02-23 21:55:12 UTC
line 7: Require API to retrieve the osd utilization
http://192.81.214.250:8000/api/v2/cluster/6c7718eb-1774-4b8e-b802-854c43241067/cli
POST
{
    "command": ["ceph", "osd", "df", "--format=json-pretty"]
}

Comment 11 Mike McCune 2016-03-28 22:39:30 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 13 Harish NV Rao 2016-05-30 08:30:27 UTC
verified in ceph version 10.2.1-3.el7cp (f6e1bde2840e1da621601bad87e15fd3f654c01e)

Comment 15 errata-xmlrpc 2016-08-23 19:29:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1755


Note You need to log in before you can comment on or make changes to this bug.