Bug 1296092 - [virtio-win][balloon] balloon driver can not be installed automately via pnputil
[virtio-win][balloon] balloon driver can not be installed automately via pnputil
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-06 05:14 EST by ShupingCui
Modified: 2016-11-04 04:49 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 04:49:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot for the issue on build 121-07042016 (130.00 KB, image/png)
2016-07-04 04:03 EDT, Gu Nini
no flags Details

  None (edit)
Description ShupingCui 2016-01-06 05:14:35 EST
Description of problem:
virtio driver can not be installed automately via pnputil

Version-Release number of selected component (if applicable):
virtio-win-prewhql-112


How reproducible:


Steps to Reproduce:
1. boot vm
/usr/libexec/qemu-kvm -name virt-tests-vm1 -sandbox off -machine pc -nodefaults -vga std -chardev socket,id=qmp_id_qmpmonitor1,path=/tmp/monitor-qmpmonitor1-20151230-170245-sw8vnIng,server,nowait -mon chardev=qmp_id_qmpmonitor1,mode=control -chardev socket,id=qmp_id_catch_monitor,path=/tmp/monitor-catch_monitor-20151230-170245-sw8vnIng,server,nowait -mon chardev=qmp_id_catch_monitor,mode=control -device pvpanic,ioport=0x505,id=idXZGfqm -chardev socket,id=serial_id_serial0,path=/tmp/serial-serial0-20151230-170245-sw8vnIng,server,nowait -device isa-serial,chardev=serial_id_serial0 -device virtio-serial-pci,id=virtio_serial_pci0,bus=pci.0,addr=03,disable-legacy=off,disable-modern=on -chardev socket,id=devvs,path=/tmp/virtio_port-vs-20151230-170245-sw8vnIng,server,nowait -device virtserialport,chardev=devvs,name=vs,id=vs,bus=virtio_serial_pci0.0 -object rng-random,filename=/dev/random,id=passthrough-pvQJxJyX -device virtio-rng-pci,id=virtio-rng-pci-CcCOiaC1,rng=passthrough-pvQJxJyX,bus=pci.0,addr=04,disable-legacy=off,disable-modern=on -chardev socket,id=seabioslog_id_20151230-170245-sw8vnIng,path=/tmp/seabios-20151230-170245-sw8vnIng,server,nowait -device isa-debugcon,chardev=seabioslog_id_20151230-170245-sw8vnIng,iobase=0x402 -device ich9-usb-ehci1,id=usb1,addr=1d.7,multifunction=on,bus=pci.0 -device ich9-usb-uhci1,id=usb1.0,multifunction=on,masterbus=usb1.0,addr=1d.0,firstport=0,bus=pci.0 -device ich9-usb-uhci2,id=usb1.1,multifunction=on,masterbus=usb1.0,addr=1d.2,firstport=2,bus=pci.0 -device ich9-usb-uhci3,id=usb1.2,multifunction=on,masterbus=usb1.0,addr=1d.4,firstport=4,bus=pci.0 -drive id=drive_image1,if=none,cache=none,snapshot=off,aio=native,format=qcow2,file=/root/staf-kvm/autotest/client/tests/virt/shared/data/images/win7-64-sp1-virtio.qcow2 -device ide-hd,id=image1,drive=drive_image1,bootindex=0,bus=ide.0,unit=0 -drive id=drive_stg,if=none,cache=none,snapshot=off,aio=native,format=qcow2,file=/root/staf-kvm/autotest/client/tests/virt/shared/data/images/storage.qcow2 -device virtio-blk-pci,id=stg,drive=drive_stg,bootindex=1,bus=pci.0,addr=05,disable-legacy=off,disable-modern=on -device virtio-scsi-pci,id=virtio_scsi_pci0,bus=pci.0,addr=06,disable-legacy=off,disable-modern=on -drive id=drive_stg1,if=none,cache=none,snapshot=off,aio=native,format=qcow2,file=/root/staf-kvm/autotest/client/tests/virt/shared/data/images/storage1.qcow2 -device scsi-hd,id=stg1,drive=drive_stg1,bootindex=2 -device rtl8139,mac=9a:dc:dd:de:df:e0,id=iduco8MM,netdev=idANxlJW,bus=pci.0,addr=07 -netdev tap,id=idANxlJW,vhost=on -device virtio-net-pci,mac=9a:e1:e2:e3:e4:e5,id=idW3beM7,vectors=4,netdev=idnwvlc8,bus=pci.0,addr=08,disable-legacy=off,disable-modern=on -netdev tap,id=idnwvlc8,vhost=on -m 4096 -smp 4,maxcpus=4,cores=2,threads=1,sockets=2 -cpu SandyBridge,hv_relaxed,+kvm_pv_unhalt,hv_spinlocks=0x1fff,hv_vapic,hv_time -drive id=drive_cd1,if=none,snapshot=off,aio=native,media=cdrom,file=/root/staf-kvm/autotest/client/tests/virt/shared/data/isos/windows/winutils.iso -device ide-cd,id=cd1,drive=drive_cd1,bootindex=3,bus=ide.0,unit=1 -drive id=drive_virtio,if=none,snapshot=off,aio=native,media=cdrom,file=/root/staf-kvm/autotest/client/tests/virt/shared/data/isos/windows/virtio-win-prewhql-0.1-112.iso -device ide-cd,id=virtio,drive=drive_virtio,bootindex=4,bus=ide.1,unit=0 -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1 -vnc :0 -rtc base=localtime,clock=host,driftfix=slew -boot order=cdn,once=c,menu=off,strict=off -enable-kvm -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=09,disable-legacy=off,disable-modern=on -monitor stdio

2. in the guest import the redhat code-sign certificate
> certutil -addstore -f TrustedPublisher C:\autotest\redhat.cer
3. install balloon driver
> pnputil -i -a e:\Ballon\w7\amd64\balloon.inf

Actual results:
Windows Security is prompts Windows can't verify the publisher of this driver software 

Expected results:
Driver should be installed successfully


Additional info:
viorng
netkvm
vioscsi
vioserial
viostor
met the same issue
Comment 2 ShupingCui 2016-01-06 21:14:49 EST
cannot reproduce this bug on virtio-win-prewhql-105.
Comment 3 lijin 2016-01-06 21:22:01 EST
According to https://bugzilla.redhat.com/show_bug.cgi?id=1110129#c14:
"Just for the record, the problem was fixed by switching to signtool from WDK 8.1
instead of WDK 7.1. So, the fix itself is not in our sources repository, but rather in the build spec file."

Hi Vadim,

Seems this issue has been fixed in build 105 but come back in build 112,could you help to check it?

Thanks.
Comment 4 Vadim Rozenfeld 2016-01-25 06:41:46 EST
(In reply to lijin from comment #3)
> According to https://bugzilla.redhat.com/show_bug.cgi?id=1110129#c14:
> "Just for the record, the problem was fixed by switching to signtool from
> WDK 8.1
> instead of WDK 7.1. So, the fix itself is not in our sources repository, but
> rather in the build spec file."
> 
> Hi Vadim,
> 
> Seems this issue has been fixed in build 105 but come back in build
> 112,could you help to check it?
> 
> Thanks.

That's strange. I cannot find anything suspicious between builds 105 and 112.
Comment 5 lijin 2016-01-25 21:09:14 EST
(In reply to Vadim Rozenfeld from comment #4)
> (In reply to lijin from comment #3)
> > According to https://bugzilla.redhat.com/show_bug.cgi?id=1110129#c14:
> > "Just for the record, the problem was fixed by switching to signtool from
> > WDK 8.1
> > instead of WDK 7.1. So, the fix itself is not in our sources repository, but
> > rather in the build spec file."
> > 
> > Hi Vadim,
> > 
> > Seems this issue has been fixed in build 105 but come back in build
> > 112,could you help to check it?
> > 
> > Thanks.
> 
> That's strange. I cannot find anything suspicious between builds 105 and 112.

Seems it's due to the redhat certificate file issue,and according to https://bugzilla.redhat.com/show_bug.cgi?id=1110129#c14,did the signtool changed between 105 and 112 during buidling?
Comment 6 Vadim Rozenfeld 2016-01-27 02:31:06 EST
(In reply to lijin from comment #5)
> (In reply to Vadim Rozenfeld from comment #4)
> > (In reply to lijin from comment #3)
> > > According to https://bugzilla.redhat.com/show_bug.cgi?id=1110129#c14:
> > > "Just for the record, the problem was fixed by switching to signtool from
> > > WDK 8.1
> > > instead of WDK 7.1. So, the fix itself is not in our sources repository, but
> > > rather in the build spec file."
> > > 
> > > Hi Vadim,
> > > 
> > > Seems this issue has been fixed in build 105 but come back in build
> > > 112,could you help to check it?
> > > 
> > > Thanks.
> > 
> > That's strange. I cannot find anything suspicious between builds 105 and 112.
> 
> Seems it's due to the redhat certificate file issue,and according to
> https://bugzilla.redhat.com/show_bug.cgi?id=1110129#c14,did the signtool
> changed between 105 and 112 during buidling?

Yes we changed RH certification, because the old one has expired. You probably need to re-import the redhat code-sign certificate.

Thanks,
Vadim.
Comment 7 lijin 2016-01-27 04:14:06 EST
(In reply to Vadim Rozenfeld from comment #6)
> (In reply to lijin from comment #5)
> > (In reply to Vadim Rozenfeld from comment #4)
> > > (In reply to lijin from comment #3)
> > > > According to https://bugzilla.redhat.com/show_bug.cgi?id=1110129#c14:
> > > > "Just for the record, the problem was fixed by switching to signtool from
> > > > WDK 8.1
> > > > instead of WDK 7.1. So, the fix itself is not in our sources repository, but
> > > > rather in the build spec file."
> > > > 
> > > > Hi Vadim,
> > > > 
> > > > Seems this issue has been fixed in build 105 but come back in build
> > > > 112,could you help to check it?
> > > > 
> > > > Thanks.
> > > 
> > > That's strange. I cannot find anything suspicious between builds 105 and 112.
> > 
> > Seems it's due to the redhat certificate file issue,and according to
> > https://bugzilla.redhat.com/show_bug.cgi?id=1110129#c14,did the signtool
> > changed between 105 and 112 during buidling?
> 
> Yes we changed RH certification, because the old one has expired. You
> probably need to re-import the redhat code-sign certificate.

Could you help to upload the new RH certification file?It's strange that I did not find any redhat certification file in certmgr.msc after install build112 device.

Thanks
Comment 11 xiagao 2016-01-31 23:53:39 EST
Also hit this issue on virtio-win-1.7.4-1.el6_7.2 (NetKVM build 98)

host info:
qemu-kvm-rhev-0.12.1.2-2.479.el6_7.4.x86_64
kernel-2.6.32-573.el6.x86_64

guest info:
Win2012r2
Comment 12 lijin 2016-02-01 23:54:01 EST
Hi Vadim,

I tried on several guests with latest redhat certification file on virtio-win-prewhql-112:

win8.1-32,win8-64,win2012R2:drivers can be installed correctly without any windows security warning;

win7-32,win2008-32:warning still prompt when use pnputil command

win7-64,win2008-64,win2008R2:drivers have some installation issue,have filed bug1303806 to track it

Could you help to check what's the difference between win8+ drivers and win8- drivers?
Comment 14 Vadim Rozenfeld 2016-02-02 01:34:58 EST
(In reply to lijin from comment #12)
> Hi Vadim,
> 
> I tried on several guests with latest redhat certification file on
> virtio-win-prewhql-112:
> 
> win8.1-32,win8-64,win2012R2:drivers can be installed correctly without any
> windows security warning;
> 
> win7-32,win2008-32:warning still prompt when use pnputil command
> 

We used to have some very weird problem on win7/ws2008 when the system was not connected to the Internet. Can you please confirm that it is not the case?

Thank you,
Vadim.

> win7-64,win2008-64,win2008R2:drivers have some installation issue,have filed
> bug1303806 to track it
> 
> Could you help to check what's the difference between win8+ drivers and
> win8- drivers?
Comment 15 lijin 2016-02-02 01:45:45 EST
(In reply to Vadim Rozenfeld from comment #14)
> (In reply to lijin from comment #12)
> > Hi Vadim,
> > 
> > I tried on several guests with latest redhat certification file on
> > virtio-win-prewhql-112:
> > 
> > win8.1-32,win8-64,win2012R2:drivers can be installed correctly without any
> > windows security warning;
> > 
> > win7-32,win2008-32:warning still prompt when use pnputil command
> > 
> 
> We used to have some very weird problem on win7/ws2008 when the system was
> not connected to the Internet. Can you please confirm that it is not the
> case?

Guests are connected to the Internet
Comment 16 Vadim Rozenfeld 2016-03-17 23:10:25 EDT
Can we please give a try to buikld 115 available at http://download.devel.redhat.com/brewroot/packages/virtio-win-prewhql/0.1/115/win/virtio-win-prewhql-0.1.zip

Thanks,
Vadim.
Comment 17 ShupingCui 2016-03-18 02:00:16 EDT
(In reply to Vadim Rozenfeld from comment #16)
> Can we please give a try to buikld 115 available at
> http://download.devel.redhat.com/brewroot/packages/virtio-win-prewhql/0.1/
> 115/win/virtio-win-prewhql-0.1.zip
> 
> Thanks,
> Vadim.

Hi Vadim,

Tried with virtio-win-prewhql-0.1-115, still met this issue.

Thanks,
Shuping
Comment 19 Vadim Rozenfeld 2016-07-04 01:42:52 EDT
Is it still the issue with drivers from build 121?
Comment 20 juzhang 2016-07-04 02:57:48 EDT
Hi Wyu,

Could you handle this issue?

Best Regards,
Junyi
Comment 21 Gu Nini 2016-07-04 04:03 EDT
Created attachment 1175847 [details]
Screenshot for the issue on build 121-07042016

(In reply to Vadim Rozenfeld from comment #19)
> Is it still the issue with drivers from build 121?


Currently for build 121, there is a prompt to check if install the driver as that in the attached screenshot; while no the problem for build 105.
Comment 26 Yu Wang 2016-07-05 05:47:50 EDT
According comment#23, this bug has been fixed, change status to verified.
Comment 28 errata-xmlrpc 2016-11-04 04:49:53 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2609.html

Note You need to log in before you can comment on or make changes to this bug.