Bug 1303806 - [virtio-win]Cannot install netkvm/balloon/viorng driver on win7-64 guests with build 112
[virtio-win]Cannot install netkvm/balloon/viorng driver on win7-64 guests wit...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win (Show other bugs)
7.3
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
: Regression, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-02-01 22:11 EST by lijin
Modified: 2016-07-03 04:23 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-03 04:23:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
balloon install error (85.51 KB, image/png)
2016-02-01 22:11 EST, lijin
no flags Details
netkvm install error (74.64 KB, image/png)
2016-02-01 22:22 EST, lijin
no flags Details
viorng install error (66.49 KB, image/png)
2016-02-01 22:22 EST, lijin
no flags Details

  None (edit)
Description lijin 2016-02-01 22:11:04 EST
Created attachment 1120301 [details]
balloon install error

Description of problem:
install netkvm/balloon/viorng driver on win7-64 guest,installation will failed as screenshot

Version-Release number of selected component (if applicable):
virtio-win-prewhql-112

How reproducible:
100%

Steps to Reproduce:
1.boot win7-64 guest
2.install balloon/netkvm/viorng driver with virtio-win-prewhql-112


Actual results:
driver install failed as "Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52)"

Expected results:
driver can be installed correctly.

Additional info:
Comment 1 lijin 2016-02-01 22:22 EST
Created attachment 1120305 [details]
netkvm install error
Comment 2 lijin 2016-02-01 22:22 EST
Created attachment 1120306 [details]
viorng install error
Comment 3 lijin 2016-02-01 22:27:31 EST
win2008R2 also hit this issue
Comment 4 Vadim Rozenfeld 2016-02-02 01:31:16 EST
what about rest of the drivers? I mostly interested in virtio-blk and virtio-scsi.
Thanks,
Vadim.
Comment 5 lijin 2016-02-02 01:40:50 EST
(In reply to Vadim Rozenfeld from comment #4)
> what about rest of the drivers? I mostly interested in virtio-blk and
> virtio-scsi.
> Thanks,
> Vadim.

scsi/blk/serial all hit this issue,we have filed three bugs before:
bug1292788,bug1248977,bug1289406
Comment 6 lijin 2016-02-04 00:03:37 EST
win2008R2 still hit this issue with build 113
Comment 7 lijin 2016-02-17 03:31:55 EST
set Regression,TestBlocker keywords due to it block win7-64/win2008-64/win2008R2 guests' driver test.
Comment 9 Yu Wang 2016-03-04 02:09:12 EST
win7-64 still hit this issue with build 114

error code 52
Comment 10 Vadim Rozenfeld 2016-03-17 23:14:57 EDT
Can we please give a try to buikld 115 available at http://download.devel.redhat.com/brewroot/packages/virtio-win-prewhql/0.1/115/win/virtio-win-prewhql-0.1.zip

Thanks,
Vadim.
Comment 11 Peixiu Hou 2016-03-18 05:00:17 EDT
Hi Vadim,

win7-64& win2008R2 still hit this issue with build 115, error code 52.

For win2008-64, update these drivers still will fail with build 115, report error code 39.


Best Regards!
Peixiu Hou
Comment 12 Peixiu Hou 2016-03-18 05:22:34 EDT
cancel needinfo
Comment 13 Yu Wang 2016-03-28 02:03:27 EDT
Reproduced this issue on virtio-win-prewhql-115
Verified this issue on virtio-win-prewhql-116

Verified guest os :
*win7-64
*win2008-64 
*win2008R2.

Verified driver

*viorng
*balloon
*vioser
*pvpanic
*netkvm
*viostor
*vioscsi

steps same as comment#0

on build 116,driver can all successfully installed 
Above all, bug has been fixed, fix version virtio-win-prewhql-116.

Thanks for your great support!:)

BR
wyu

Note You need to log in before you can comment on or make changes to this bug.