Bug 129613 - (IT_45016) [RHEL3] Nautilus crashes when programs under \'Start Here\' are clicked in GNOME
[RHEL3] Nautilus crashes when programs under \'Start Here\' are clicked in GNOME
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gnome-vfs2 (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
Jay Turner
:
: 126986 (view as bug list)
Depends On:
Blocks: 136201
  Show dependency treegraph
 
Reported: 2004-08-10 17:53 EDT by Alexandre Oliva
Modified: 2015-01-07 19:08 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:21:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Stack trace from a crash on an x86_64 box (7.33 KB, text/plain)
2004-08-10 17:59 EDT, Alexandre Oliva
no flags Details

  None (edit)
Description Alexandre Oliva 2004-08-10 17:53:50 EDT
In GNOME, multiple programs such as "Applications", "Preferences" and
"System Settings", all under the "Start Here" group on the desktop
crash when clicked with the following error message:
"Error: Application "nautilus" (process <pid>) has crashed due to a
fatal error. (Segmentation fault)."

This issue has been reproduced on the following OS images:
1) RHEL 3 Gold x86
2) RHEL 3 U2 x86
3) RHEL 3 U2 EM64T
4) RHEL 3 U3 Public Beta EM64T

***NOTE*** This issue is more readily reproducable when you have > 1
processors with HT enabled and running the SMP kernel.

fhirtz says:
In my testing, this isn't terribly hard to replicate on either ia32 or
EM64T. It just invloves opening "start here" and randomly opening
folders. Periodically the segfault pops under the active window.
Comment 2 Alexandre Oliva 2004-08-10 17:59:30 EDT
Created attachment 102598 [details]
Stack trace from a crash on an x86_64 box
Comment 3 Alexandre Oliva 2004-08-14 10:28:18 EDT
I've been able to duplicate the problem several times.  It looks like
memory corruption, possibly caused by lack of synchronization between
threads, because every time I get a segfault in GDB, it's for
different reasons.  Often it's within memmove, asked to copy a
negative byte count; sometimes it's in g_main_context_check.

I've been able to duplicate the problem without the `Start Here' icon:
entering say `applications://' or `preferences://' in the location bar
is enough.
Comment 5 Alexander Larsson 2004-08-26 08:52:17 EDT
Sounds like this is a problem in the vfolder code in gnome-vfs2.
(this is what handles things like applications:// and preferences://)
Comment 6 Alexander Larsson 2004-08-26 09:52:14 EDT
*** Bug 126986 has been marked as a duplicate of this bug. ***
Comment 14 John (J5) Palmieri 2005-02-10 14:42:36 EST
Was able to reproduce the crash in gdb and got a backtrace that
pointed to FAM as the culprit.  Thought it might be related to
bug#140317 so I updated gnome-vfs to the one I had already built as a
U5 errata.  After clicking on the folders in start here from some time
I have no been able to reproduce the crash.  Adding this bug to errata.
Comment 15 Tim Powers 2005-05-19 09:45:04 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-148.html
Comment 19 Larry Troan 2005-07-05 12:01:18 EDT
Can we get this on the CANFIX list since Dell says it was never fixed in U5...
Comment 21 John (J5) Palmieri 2005-07-12 18:15:32 EDT
I can't reproduce this on my fresh RHEL3 U5 dual Xeon running with the smp
kernel.  I've been trying all day and it just won't crash.  I know before the U5
update I could get it to crash within 20 or so clicks.  Can we get a
confirmation from DELL on the exact conditions they are seeing this under?  How
long does it take them to reproduce the crash and is it less frequent with U5
than with older releases?

QA is working on porting their dogtail testing framework to RHEL 3 and writting
a script that can automate the task of clicking on the start here buttons.  It
may be able to get this bug unearthed better than I can do clicking manually. 
Comment 24 RHEL Product and Program Management 2007-10-19 15:21:03 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.