Bug 1296820 - kernel-4.3.3-300.fc23.x86_64 OOPs during bootup
Summary: kernel-4.3.3-300.fc23.x86_64 OOPs during bootup
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau
Version: 23
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ben Skeggs
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1298595 1298885 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-01-08 08:28 UTC by Ralf Corsepius
Modified: 2016-01-26 18:25 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-01-26 18:25:17 UTC
Type: Bug


Attachments (Terms of Use)
dmesg from booting with kernel-4.3.3-300.bz1296820.fc23.x86_64 (69.58 KB, text/plain)
2016-01-08 17:07 UTC, Ralf Corsepius
no flags Details

Description Ralf Corsepius 2016-01-08 08:28:21 UTC
Description of problem:

kernel-4.3.3-300.fc23.x86_64 immediately OOPs at bootup on one of my machines:
...
Jan 08 08:43:23 troy kernel: BUG: unable to handle kernel NULL pointer dereference at           (null)
Jan 08 08:43:23 troy kernel: IP: [<ffffffffa02f23e5>] nvkm_pmu_pgob+0x5/0x20 [nouveau]
Jan 08 08:43:23 troy kernel: PGD 21a20b067 PUD 21a28c067 PMD 0 
Jan 08 08:43:23 troy kernel: Oops: 0000 [#1] SMP 
Jan 08 08:43:23 troy kernel: Modules linked in: nf_conntrack_netbios_ns nf_conntrack_broadcast ip6t_rpfilter ip6t_REJECT nf_reject_ipv6 xt_conntrack ebtable_filter ebtable_nat ebtable_broute bridge stp llc ebtables ip6table_mangle ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_raw ip6table_security ip6table_filter ip6_tables iptable_mangle iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_raw iptable_security bnep intel_rapl iosf_mbi x86_pkg_temp_thermal coretemp kvm_intel kvm iTCO_wdt iTCO_vendor_support vfat fat crct10dif_pclmul crc32_pclmul arc4 crc32c_intel uvcvideo rtl8723be btcoexist rtl8723_common rtl_pci videobuf2_vmalloc videobuf2_core rtlwifi snd_soc_rt5640 snd_soc_rl6231 mac80211 snd_hda_codec_realtek snd_soc_core snd_hda_codec_generic snd_hda_codec_hdmi
Jan 08 08:43:23 troy kernel:  videobuf2_memops v4l2_common btusb videodev snd_hda_intel btrtl cfg80211 btbcm snd_hda_codec i2c_i801 btintel bluetooth media mei_me snd_hda_core joydev mei snd_hwdep snd_compress snd_pcm_dmaengine ac97_bus snd_seq lpc_ich snd_seq_device snd_pcm ideapad_laptop shpchp snd_timer sparse_keymap rfkill snd elan_i2c soundcore dw_dmac dw_dmac_core i2c_designware_platform i2c_designware_core snd_soc_sst_acpi nfsd auth_rpcgss nfs_acl lockd grace sunrpc hid_multitouch nouveau i915 mxm_wmi ttm i2c_algo_bit drm_kms_helper r8169 drm serio_raw mii wmi sdhci_acpi sdhci mmc_core video i2c_hid fjes
Jan 08 08:43:23 troy kernel: CPU: 1 PID: 1440 Comm: Xorg Not tainted 4.3.3-300.fc23.x86_64 #1
Jan 08 08:43:23 troy kernel: Hardware name: LENOVO 20404/Lenovo Flex 2-14, BIOS A0CN37WW 07/14/2015
Jan 08 08:43:23 troy kernel: task: ffff880222f48000 ti: ffff880223258000 task.ti: ffff880223258000
Jan 08 08:43:23 troy kernel: RIP: 0010:[<ffffffffa02f23e5>]  [<ffffffffa02f23e5>] nvkm_pmu_pgob+0x5/0x20 [nouveau]
Jan 08 08:43:23 troy kernel: RSP: 0018:ffff88022325baa0  EFLAGS: 00010282
Jan 08 08:43:23 troy kernel: RAX: ffff88003fa01000 RBX: ffff880221d8c008 RCX: 0000000000000018
Jan 08 08:43:23 troy kernel: RDX: ffffffffa0321710 RSI: 0000000000000000 RDI: 0000000000000000
Jan 08 08:43:23 troy kernel: RBP: ffff88022325baf0 R08: 0000000bec016f56 R09: ffff880221d8c010
Jan 08 08:43:23 troy kernel: R10: ffffffffa03210f0 R11: ffff88022325bdb0 R12: ffff880221d8c018
Jan 08 08:43:23 troy kernel: R13: ffff880222e05800 R14: ffff88003fa01000 R15: ffff880224af0018
Jan 08 08:43:23 troy kernel: FS:  00007faab5748a00(0000) GS:ffff88022f240000(0000) knlGS:0000000000000000
Jan 08 08:43:23 troy kernel: CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
Jan 08 08:43:23 troy kernel: CR2: 0000000000000000 CR3: 000000021caa1000 CR4: 00000000001406e0
Jan 08 08:43:23 troy kernel: Stack:
Jan 08 08:43:23 troy kernel:  ffffffffa0321742 ffff88022325bab8 ffffffff8178109e ffff88022325baf8
Jan 08 08:43:23 troy kernel:  ffff88003fa01000 000000041a063c47 ffff880221d8c018 ffff880222e05800
Jan 08 08:43:23 troy kernel:  ffff880221d8c010 ffff880224af0018 ffff88022325bb00 ffffffffa03163dc
Jan 08 08:43:23 troy kernel: Call Trace:
Jan 08 08:43:23 troy kernel:  [<ffffffffa0321742>] ? gf100_gr_oneinit+0x32/0x2a0 [nouveau]
Jan 08 08:43:23 troy kernel:  [<ffffffff8178109e>] ? _raw_spin_unlock_irqrestore+0xe/0x10
Jan 08 08:43:23 troy kernel:  [<ffffffffa03163dc>] nvkm_gr_on

Version-Release number of selected component (if applicable):
kernel-4.3.3-300.fc23.x86_64

How reproducible:
Always on one machine.

Steps to Reproduce:
No idea. I tried this kernel on 2 machines. 
On one machine (A Lenovo Flex 2 w/ i3-4010U/Haswell) the OOPs always happens,
on the other one (Core 2 Duo E6750) it doesn't happen.

Comment 1 Josh Boyer 2016-01-08 14:32:23 UTC
Please test this scratch build when it completes and let us know if the issue is resolved.  If not, please attach the dmesg output from that kernel.

http://koji.fedoraproject.org/koji/taskinfo?taskID=12467013

Comment 2 Ralf Corsepius 2016-01-08 17:07:25 UTC
Created attachment 1112936 [details]
dmesg from booting with kernel-4.3.3-300.bz1296820.fc23.x86_64

This kernel boots and doesn't OOPs immediately on the Lenovo.

Am I correct in assuming the OOPs is related to nouveau? This Lenovo is an "NV-Optimus"-equipped and has 2 GPUs (NV 820M + Intel HD Graphics 4400).
I don't recall, why nouveau is installed and being used.

Comment 3 Josh Boyer 2016-01-08 17:36:31 UTC
Thanks for testing.

Ben, you might want to send upstream commit 579b7c58215329803ce184704463de09f0f310ac to stable.

Comment 4 Josh Boyer 2016-01-15 01:10:08 UTC
*** Bug 1298595 has been marked as a duplicate of this bug. ***

Comment 5 Josh Boyer 2016-01-15 18:59:08 UTC
*** Bug 1298885 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2016-01-15 19:25:20 UTC
kernel-4.3.3-301.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-26e19f042a

Comment 7 Fedora Update System 2016-01-17 14:23:15 UTC
kernel-4.3.3-301.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-26e19f042a

Comment 8 Fedora Update System 2016-01-19 12:55:00 UTC
kernel-4.3.3-302.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-db9fedd7c4

Comment 9 Alessandro Guido 2016-01-20 10:50:13 UTC
Fixed in 4.3.3-301.fc23.x86_64

Comment 10 Fedora Update System 2016-01-20 21:52:21 UTC
kernel-4.3.3-301.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2016-01-22 04:58:39 UTC
kernel-4.3.3-303.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-b59fd603be

Comment 12 Fedora Update System 2016-01-26 18:23:19 UTC
kernel-4.3.3-303.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.