Bug 1298369 - UI: VM Explorers - link to clear applied filter is missing from title after applying filters on all VM explorers
UI: VM Explorers - link to clear applied filter is missing from title after a...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Dávid Halász
Taras Lehinevych
:
: 1298367 1298368 (view as bug list)
Depends On:
Blocks: 1298706
  Show dependency treegraph
 
Reported: 2016-01-13 17:41 EST by Harpreet Kataria
Modified: 2016-08-02 21:33 EDT (History)
9 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1298706 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:29:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
missing clear link (225.81 KB, image/png)
2016-01-13 17:43 EST, Harpreet Kataria
no flags Details
clear link appears after browser refresh (208.23 KB, image/png)
2016-01-13 17:47 EST, Harpreet Kataria
no flags Details

  None (edit)
Description Harpreet Kataria 2016-01-13 17:41:23 EST
Description of problem: "clear" link is missing from title after applying filters on all VM explorers


Version-Release number of selected component (if applicable): 


How reproducible: 100%


Steps to Reproduce:
1. Go To Infrastructure/Virtual Machines explorer
2. Change accordion to VMs, apply any filter from the tree, title on the right side should show title of applied filter along with the link to clear the applied filter.
3.

Actual results: link to clear search/filter is missing, it appears when browser is refreshed or if i go out of VM explorer and come back to it.


Expected results: clear link should be displayed after search/filter is applied.


Additional info:
Comment 1 Harpreet Kataria 2016-01-13 17:43 EST
Created attachment 1114542 [details]
missing clear link
Comment 2 Harpreet Kataria 2016-01-13 17:46:20 EST
*** Bug 1298368 has been marked as a duplicate of this bug. ***
Comment 3 Harpreet Kataria 2016-01-13 17:47 EST
Created attachment 1114543 [details]
clear link appears after browser refresh
Comment 4 Harpreet Kataria 2016-01-13 17:48:21 EST
*** Bug 1298367 has been marked as a duplicate of this bug. ***
Comment 8 CFME Bot 2016-01-21 17:07:24 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/bfad3ef54ede5b33ef86e6d87d0292599680ddef

commit bfad3ef54ede5b33ef86e6d87d0292599680ddef
Author:     Dávid Halász <dhalasz@redhat.com>
AuthorDate: Wed Jan 20 09:01:25 2016 +0100
Commit:     Dávid Halász <dhalasz@redhat.com>
CommitDate: Wed Jan 20 09:01:25 2016 +0100

    Fixed visibility of the filter clearing link
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1298369

 app/presenters/explorer_presenter.rb | 2 +-
 app/views/layouts/_content.html.haml | 3 ++-
 2 files changed, 3 insertions(+), 2 deletions(-)
Comment 9 Taras Lehinevych 2016-04-20 09:01:02 EDT
Verified in 5.6.0.1-beta2
Comment 11 errata-xmlrpc 2016-06-29 11:29:25 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.