Bug 1298401 - Memcached fails to start in ipv6 environment
Memcached fails to start in ipv6 environment
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: memcached (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
urgent Severity high
: z4
: 7.0 (Kilo)
Assigned To: hguemar
Marius Cornea
: Triaged, ZStream
Depends On:
Blocks: 1298603 1299075
  Show dependency treegraph
 
Reported: 2016-01-13 19:15 EST by Marius Cornea
Modified: 2016-04-20 03:48 EDT (History)
10 users (show)

See Also:
Fixed In Version: memcached-1.4.15-9.1.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1298603 1299075 (view as bug list)
Environment:
Last Closed: 2016-02-18 11:10:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marius Cornea 2016-01-13 19:15:46 EST
Description of problem:
Memcached fails to start in ipv6 environment:
overcloud-controller-0 systemd[1]: Starting Cluster Controlled memcached...
overcloud-controller-0 memcached[9948]: Invalid port number: "fd00:fd00:2000:f816:3eff:feae:9393"failed to listen on TCP port 11211: Success
overcloud-controller-0 systemd[1]: memcached.service: main process exited, code=exited, status=71/n/a
overcloud-controller-0 systemd[1]: Unit memcached.service entered failed state.

Version-Release number of selected component (if applicable):
I'm doing the test following the instructions in:
https://etherpad.openstack.org/p/tripleo-ipv6-support
and enabling pacemaker by passing an additional $THT/environments/puppet-pacemaker.yaml environment file


How reproducible:
100%

Steps to Reproduce:
1. Apply workarounds for BZ#1295986 and BZ#1297850
2. Deploy ipv6 enabled overcloud

Actual results:
systemd[1]: Starting Cluster Controlled memcached...
memcached[9948]: Invalid port number: "fd00:fd00:2000:f816:3eff:feae:9393"failed to listen on TCP port 11211: Success


Expected results:
memcached gets started

Additional info:
[root@overcloud-controller-0 ~]# cat /etc/sysconfig/memcached 
PORT="11211"
USER="memcached"
MAXCONN="8192"
CACHESIZE="15087"
OPTIONS="-l fd00:fd00:fd00:2000:f816:3eff:feae:9393 -U 11211 -t 4 >> /var/log/memcached.log 2>&1"

Upstream fix:
https://github.com/memcached/memcached/pull/98
Comment 1 Emilien Macchi 2016-01-13 23:31:57 EST
Assigned to OPM because I think it's a bug in puppet-memcached. We're looking at it.
Comment 2 Marius Cornea 2016-01-14 06:09:46 EST
The issue has been reported here:
https://github.com/yeshm/memcached/issues/310

and it appears to have been solved in release 1.4.25:
https://github.com/memcached/memcached/wiki/ReleaseNotes1425

The version installed on my system is memcached-1.4.15-9.el7.x86_64
Comment 4 Marius Cornea 2016-01-19 05:42:19 EST
memcached-1.4.15-9.1.el7ost.x86_64
[root@overcloud-controller-0 ~]# systemctl status memcached
● memcached.service - Cluster Controlled memcached
   Loaded: loaded (/usr/lib/systemd/system/memcached.service; disabled; vendor preset: disabled)
  Drop-In: /run/systemd/system/memcached.service.d
           └─50-pacemaker.conf
   Active: active (running) since Tue 2016-01-19 05:41:42 EST; 1s ago
 Main PID: 5907 (memcached)
   CGroup: /system.slice/memcached.service
           └─5907 /usr/bin/memcached -u memcached -p 11211 -m 15087 -c 8192 -l fd00:fd00:fd00:2000:f816:3eff:feeb:3100 -U 11211 -t 8 >> /var/log/memcached.log 2>&1

Jan 19 05:41:42 overcloud-controller-0.localdomain systemd[1]: Started Cluster Controlled memcached.
Jan 19 05:41:42 overcloud-controller-0.localdomain systemd[1]: Starting Cluster Controlled memcached...
Warning: memcached.service changed on disk. Run 'systemctl daemon-reload' to reload units.
[root@overcloud-controller-0 ~]# netstat -tupan | grep 11211
tcp6       0      0 fd00:fd00:fd00:20:11211 :::*                    LISTEN      5907/memcached      
udp6       0      0 fd00:fd00:fd00:20:11211 :::*                                5907/memcached
Comment 7 errata-xmlrpc 2016-02-18 11:10:21 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0259.html

Note You need to log in before you can comment on or make changes to this bug.