Bug 1298603 - Memcached fails to start in ipv6 environment
Memcached fails to start in ipv6 environment
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: memcached (Show other bugs)
7.3
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Miroslav Lichvar
Leos Pol
https://github.com/yeshm/memcached/is...
: ZStream
Depends On: 1298401 1299075
Blocks: 1366158
  Show dependency treegraph
 
Reported: 2016-01-14 09:26 EST by Lon Hohberger
Modified: 2016-11-03 20:35 EDT (History)
11 users (show)

See Also:
Fixed In Version: memcached-1.4.15-10.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1298401
: 1366158 (view as bug list)
Environment:
Last Closed: 2016-11-03 20:35:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lon Hohberger 2016-01-14 09:26:13 EST
+++ This bug was initially created as a clone of Bug #1298401 +++

Description of problem:
Memcached fails to start in ipv6 environment:
overcloud-controller-0 systemd[1]: Starting Cluster Controlled memcached...
overcloud-controller-0 memcached[9948]: Invalid port number: "fd00:fd00:2000:f816:3eff:feae:9393"failed to listen on TCP port 11211: Success
overcloud-controller-0 systemd[1]: memcached.service: main process exited, code=exited, status=71/n/a
overcloud-controller-0 systemd[1]: Unit memcached.service entered failed state.

Version-Release number of selected component (if applicable):
I'm doing the test following the instructions in:
https://etherpad.openstack.org/p/tripleo-ipv6-support
and enabling pacemaker by passing an additional $THT/environments/puppet-pacemaker.yaml environment file


How reproducible:
100%

Steps to Reproduce:
1. Apply workarounds for BZ#1295986 and BZ#1297850
2. Deploy ipv6 enabled overcloud

Actual results:
systemd[1]: Starting Cluster Controlled memcached...
memcached[9948]: Invalid port number: "fd00:fd00:2000:f816:3eff:feae:9393"failed to listen on TCP port 11211: Success


Expected results:
memcached gets started

Additional info:
[root@overcloud-controller-0 ~]# cat /etc/sysconfig/memcached 
PORT="11211"
USER="memcached"
MAXCONN="8192"
CACHESIZE="15087"
OPTIONS="-l fd00:fd00:fd00:2000:f816:3eff:feae:9393 -U 11211 -t 4 >> /var/log/memcached.log 2>&1"

Upstream fix:
https://github.com/memcached/memcached/pull/98

--- Additional comment from Emilien Macchi on 2016-01-13 23:31:57 EST ---

Assigned to OPM because I think it's a bug in puppet-memcached. We're looking at it.

--- Additional comment from Marius Cornea on 2016-01-14 06:09:46 EST ---

The issue has been reported here:
https://github.com/yeshm/memcached/issues/310

and it appears to have been solved in release 1.4.25:
https://github.com/memcached/memcached/wiki/ReleaseNotes1425

The version installed on my system is memcached-1.4.15-9.el7.x86_64
Comment 1 Lon Hohberger 2016-01-14 09:27:54 EST
Effectively, OpenStack can't be deployed on RHEL 7.2 using ipv6.
Comment 2 Miroslav Lichvar 2016-01-14 10:02:31 EST
The upstream patch applies cleanly to 1.4.15 and seems to work as expected.
Comment 10 errata-xmlrpc 2016-11-03 20:35:46 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2213.html

Note You need to log in before you can comment on or make changes to this bug.