Bug 1299075 - Memcached fails to start in ipv6 environment
Memcached fails to start in ipv6 environment
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: memcached (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
urgent Severity high
: ga
: 8.0 (Liberty)
Assigned To: hguemar
Asaf Hirshberg
: Triaged
Depends On: 1298401
Blocks: 1298603
  Show dependency treegraph
 
Reported: 2016-01-15 16:44 EST by Jon Schlueter
Modified: 2016-04-07 17:23 EDT (History)
11 users (show)

See Also:
Fixed In Version: memcached-1.4.15-9.1.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, memcached was unable to bind IPv6 addresses, resulting in memcached failing to start in IPv6 environments. This update addresses this issue, with memcached-1.4.15-9.1.el7ost now IPv6-enabled.
Story Points: ---
Clone Of: 1298401
Environment:
Last Closed: 2016-04-07 17:23:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Schlueter 2016-01-15 16:44:38 EST
+++ This bug was initially created as a clone of Bug #1298401 +++

Description of problem:
Memcached fails to start in ipv6 environment:
overcloud-controller-0 systemd[1]: Starting Cluster Controlled memcached...
overcloud-controller-0 memcached[9948]: Invalid port number: "fd00:fd00:2000:f816:3eff:feae:9393"failed to listen on TCP port 11211: Success
overcloud-controller-0 systemd[1]: memcached.service: main process exited, code=exited, status=71/n/a
overcloud-controller-0 systemd[1]: Unit memcached.service entered failed state.

Version-Release number of selected component (if applicable):
I'm doing the test following the instructions in:
https://etherpad.openstack.org/p/tripleo-ipv6-support
and enabling pacemaker by passing an additional $THT/environments/puppet-pacemaker.yaml environment file


How reproducible:
100%

Steps to Reproduce:
1. Apply workarounds for BZ#1295986 and BZ#1297850
2. Deploy ipv6 enabled overcloud

Actual results:
systemd[1]: Starting Cluster Controlled memcached...
memcached[9948]: Invalid port number: "fd00:fd00:2000:f816:3eff:feae:9393"failed to listen on TCP port 11211: Success


Expected results:
memcached gets started

Additional info:
[root@overcloud-controller-0 ~]# cat /etc/sysconfig/memcached 
PORT="11211"
USER="memcached"
MAXCONN="8192"
CACHESIZE="15087"
OPTIONS="-l fd00:fd00:fd00:2000:f816:3eff:feae:9393 -U 11211 -t 4 >> /var/log/memcached.log 2>&1"

Upstream fix:
https://github.com/memcached/memcached/pull/98

--- Additional comment from Emilien Macchi on 2016-01-13 23:31:57 EST ---

Assigned to OPM because I think it's a bug in puppet-memcached. We're looking at it.

--- Additional comment from Marius Cornea on 2016-01-14 06:09:46 EST ---

The issue has been reported here:
https://github.com/yeshm/memcached/issues/310

and it appears to have been solved in release 1.4.25:
https://github.com/memcached/memcached/wiki/ReleaseNotes1425

The version installed on my system is memcached-1.4.15-9.el7.x86_64
Comment 5 Asaf Hirshberg 2016-01-31 06:08:58 EST
Verified on 2016-01-21-1.

[root@overcloud-controller-0 ~]# systemctl status memcached
● memcached.service - Cluster Controlled memcached
   Loaded: loaded (/usr/lib/systemd/system/memcached.service; disabled; vendor preset: disabled)
  Drop-In: /run/systemd/system/memcached.service.d
           └─50-pacemaker.conf
   Active: active (running) since Tue 2016-01-26 07:54:58 EST; 4 days ago
 Main PID: 26283 (memcached)
   CGroup: /system.slice/memcached.service
           └─26283 /usr/bin/memcached -u memcached -p 11211 -m 30400 -c 8192 -l 2620:52:0:23ae::13 -U 11211 -t 12 >> /var/log/memcached.log 2>&1

Warning: Journal has been rotated since unit was started. Log output is incomplete or unavailable.

[root@overcloud-controller-0 ~]# memcached -vvv -u root
slab class   1: chunk size        96 perslab   10922
slab class   2: chunk size       120 perslab    8738
slab class   3: chunk size       152 perslab    6898
slab class   4: chunk size       192 perslab    5461
slab class   5: chunk size       240 perslab    4369
slab class   6: chunk size       304 perslab    3449
slab class   7: chunk size       384 perslab    2730
slab class   8: chunk size       480 perslab    2184
slab class   9: chunk size       600 perslab    1747
slab class  10: chunk size       752 perslab    1394
slab class  11: chunk size       944 perslab    1110
slab class  12: chunk size      1184 perslab     885
slab class  13: chunk size      1480 perslab     708
slab class  14: chunk size      1856 perslab     564
slab class  15: chunk size      2320 perslab     451
slab class  16: chunk size      2904 perslab     361
slab class  17: chunk size      3632 perslab     288
slab class  18: chunk size      4544 perslab     230
slab class  19: chunk size      5680 perslab     184
slab class  20: chunk size      7104 perslab     147
slab class  21: chunk size      8880 perslab     118
slab class  22: chunk size     11104 perslab      94
slab class  23: chunk size     13880 perslab      75
slab class  24: chunk size     17352 perslab      60
slab class  25: chunk size     21696 perslab      48
slab class  26: chunk size     27120 perslab      38
slab class  27: chunk size     33904 perslab      30
slab class  28: chunk size     42384 perslab      24
slab class  29: chunk size     52984 perslab      19
slab class  30: chunk size     66232 perslab      15
slab class  31: chunk size     82792 perslab      12
slab class  32: chunk size    103496 perslab      10
slab class  33: chunk size    129376 perslab       8
slab class  34: chunk size    161720 perslab       6
slab class  35: chunk size    202152 perslab       5
slab class  36: chunk size    252696 perslab       4
slab class  37: chunk size    315872 perslab       3
slab class  38: chunk size    394840 perslab       2
slab class  39: chunk size    493552 perslab       2
slab class  40: chunk size    616944 perslab       1
slab class  41: chunk size    771184 perslab       1
slab class  42: chunk size   1048576 perslab       1
<26 server listening (auto-negotiate)
<27 send buffer was 212992, now 268435456
<28 send buffer was 212992, now 268435456
<27 server listening (udp)
<27 server listening (udp)
<27 server listening (udp)
<27 server listening (udp)
<28 server listening (udp)
<28 server listening (udp)
<28 server listening (udp)
<28 server listening (udp)
Comment 6 errata-xmlrpc 2016-04-07 17:23:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.